summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorThomas Habets <thomas@habets.pp.se>2009-09-20 18:01:14 +0200
committerThomas Habets <thomas@habets.pp.se>2009-09-20 18:01:14 +0200
commitf48fb81dc1f3f0ed16df7ed9a51b43a4f0a49048 (patch)
tree5404f11d854b0dbb0ce5a3190b3d8970c8166439 /configure.ac
parentf54d3ca95730a6dd1e5d657d2455fa837431d4ee (diff)
downloadarping-f48fb81dc1f3f0ed16df7ed9a51b43a4f0a49048.tar.gz
Actual working autotools build system
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 7 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index 20ae420..a1d363c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3,7 +3,7 @@
AC_PREREQ(2.61)
AC_INIT(arping, 2.08, thomas@habets.pp.se)
-AC_CONFIG_SRCDIR([arping.c])
+AC_CONFIG_SRCDIR([src/arping.c])
AM_INIT_AUTOMAKE
AM_MAINTAINER_MODE
AC_CONFIG_HEADER(config.h)
@@ -26,12 +26,12 @@ AC_CHECK_LIB([socket], [socket])
# Checks for header files.
AC_HEADER_STDC
-AC_CHECK_HEADERS([
-arpa/inet.h
-netinet/in.h
-stdlib.h
-sys/socket.h
-sys/time.h
+AC_CHECK_HEADERS([\
+arpa/inet.h \
+netinet/in.h \
+stdlib.h \
+sys/socket.h \
+sys/time.h \
unistd.h])
# Checks for typedefs, structures, and compiler characteristics.