summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorThomas Habets <thomas@habets.pp.se>2009-09-20 18:26:44 +0200
committerThomas Habets <thomas@habets.pp.se>2009-09-20 18:26:44 +0200
commitbeda5626ecfe9f27680912d1982d270c69f72405 (patch)
tree97cb62098bc8fe39ded19b838170e077a7850353 /configure.ac
parent06dbac2c3c7bf8c1ba9566aa69c2477d1a50aa2c (diff)
downloadarping-beda5626ecfe9f27680912d1982d270c69f72405.tar.gz
autoconf: make sure libpcap exists
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 5 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index e060c62..1ad5e82 100644
--- a/configure.ac
+++ b/configure.ac
@@ -19,14 +19,13 @@ AC_CHECK_LIB([net], [libnet_name_resolve],
[AC_MSG_ERROR([libnet 1.0.x found. Arping 2.x requires libnet 1.1.x])])
AC_CHECK_LIB([net], [libnet_init], ,[AC_MSG_ERROR([libnet 1.1.x not found])])
+AC_CHECK_LIB([pcap], [pcap_open_live], ,[AC_MSG_ERROR([libpcap not found])])
+# What's this for?
+#AC_CHECK_LIB([nsl], [main])
-# FIXME: Replace `main' with a function in `-lnsl':
-AC_CHECK_LIB([nsl], [main])
-# FIXME: Replace `main' with a function in `-lpcap':
-AC_CHECK_LIB([pcap], [pcap_open_live])
-# FIXME: Replace `main' with a function in `-lsocket':
-AC_CHECK_LIB([socket], [socket])
+# Not needed, right?
+#AC_CHECK_LIB([socket], [socket])
# Checks for header files.
AC_HEADER_STDC