summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorThomas Habets <thomas@habets.pp.se>2009-09-20 17:50:36 +0200
committerThomas Habets <thomas@habets.pp.se>2009-09-20 17:50:36 +0200
commitb707e83312bc2ff385663f20063a7f66d4173434 (patch)
tree83aea391352db9bd5be20e51b22797d6b180467d /configure.ac
parent21fbc5dd3453a2d23468b5aea2b1331059f26220 (diff)
downloadarping-b707e83312bc2ff385663f20063a7f66d4173434.tar.gz
Start of autoconf build system
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac48
1 files changed, 48 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..f8413fc
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,48 @@
+# -*- Autoconf -*-
+# Process this file with autoconf to produce a configure script.
+
+AC_PREREQ(2.61)
+AC_INIT(arping, 2.08, thomas@habets.pp.se)
+AC_CONFIG_SRCDIR([arping.c])
+AC_CONFIG_HEADER(config.h)
+
+# Checks for programs.
+AC_PROG_CC
+AC_PROG_INSTALL
+AC_PROG_MAKE_SET
+
+# Checks for libraries.
+# FIXME: Replace `main' with a function in `-lnet':
+AC_CHECK_LIB([net], [libnet_init])
+# FIXME: Replace `main' with a function in `-lnsl':
+AC_CHECK_LIB([nsl], [main])
+# FIXME: Replace `main' with a function in `-lpcap':
+AC_CHECK_LIB([pcap], [pcap_open_live])
+# FIXME: Replace `main' with a function in `-lsocket':
+AC_CHECK_LIB([socket], [socket])
+
+# Checks for header files.
+AC_HEADER_STDC
+AC_CHECK_HEADERS([
+arpa/inet.h
+netinet/in.h
+stdlib.h
+sys/socket.h
+sys/time.h
+unistd.h])
+
+# Checks for typedefs, structures, and compiler characteristics.
+AC_C_CONST
+AC_HEADER_TIME
+AC_C_VOLATILE
+
+# Checks for library functions.
+AC_PROG_GCC_TRADITIONAL
+AC_FUNC_MEMCMP
+AC_FUNC_SELECT_ARGTYPES
+AC_FUNC_SETVBUF_REVERSED
+AC_TYPE_SIGNAL
+AC_CHECK_FUNCS([gettimeofday memset select strchr strdup strerror strstr])
+
+AC_CONFIG_FILES([Makefile])
+AC_OUTPUT