summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorThomas Habets <habets@google.com>2014-12-05 09:23:55 +0000
committerThomas Habets <habets@google.com>2014-12-05 11:02:05 +0000
commit995c5d9b93678267b5fcdaa93fd9022c58991f43 (patch)
tree4b7ca0d7d068513321f1f369de99aabf48b11be1 /configure.ac
parent6592576c979c0f0d85d0c15e1bab6a874cb5eb1c (diff)
downloadarping-995c5d9b93678267b5fcdaa93fd9022c58991f43.tar.gz
Use pcap_create() instead of pcap_open_live(), when available.
pcap_open_live() does the same thing this code does, but future commits will add stuff that only works when using pcap_create().
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index d451cae..8a1247c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -65,7 +65,7 @@ AC_FUNC_SELECT_ARGTYPES
AC_FUNC_SETVBUF_REVERSED
AC_TYPE_SIGNAL
AC_CHECK_FUNCS([gettimeofday memset select strchr strdup strerror strstr \
-getifaddrs cap_init])
+getifaddrs cap_init pcap_create])
if test x$ac_cv_func_getifaddrs = xyes; then
AC_LIBOBJ([findif_getifaddrs])