summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorThomas Habets <thomas@habets.pp.se>2009-09-20 18:20:18 +0200
committerThomas Habets <thomas@habets.pp.se>2009-09-20 18:20:18 +0200
commit6e7a5efbf9e67e4b38316ee37fca025444a6bb38 (patch)
treec69128fe9f1a5794c56ba5366e32dcf15eb5483d /configure.ac
parent910c9a9d10e137c2c26271d4bd6aa8059cc37a7b (diff)
downloadarping-6e7a5efbf9e67e4b38316ee37fca025444a6bb38.tar.gz
Make sure libnet exists and is 1.1.x
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 14 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index a1d363c..e060c62 100644
--- a/configure.ac
+++ b/configure.ac
@@ -15,8 +15,12 @@ AC_PROG_INSTALL
AC_PROG_MAKE_SET
# Checks for libraries.
-# FIXME: Replace `main' with a function in `-lnet':
-AC_CHECK_LIB([net], [libnet_init])
+AC_CHECK_LIB([net], [libnet_name_resolve],
+ [AC_MSG_ERROR([libnet 1.0.x found. Arping 2.x requires libnet 1.1.x])])
+AC_CHECK_LIB([net], [libnet_init], ,[AC_MSG_ERROR([libnet 1.1.x not found])])
+
+
+
# FIXME: Replace `main' with a function in `-lnsl':
AC_CHECK_LIB([nsl], [main])
# FIXME: Replace `main' with a function in `-lpcap':
@@ -49,3 +53,11 @@ AC_CHECK_FUNCS([gettimeofday memset select strchr strdup strerror strstr])
AC_CONFIG_FILES([Makefile])
AC_OUTPUT
+
+echo "
+ $PACKAGE_NAME version $PACKAGE_VERSION
+ Prefix.........: $prefix
+ Debug Build....: $debug
+ C Compiler.....: $CC $CFLAGS $CPPFLAGS
+ Linker.........: $LD $LDFLAGS $LIBS
+"