summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorThomas Habets <thomas@habets.pp.se>2009-09-30 13:09:27 +0200
committerThomas Habets <thomas@habets.pp.se>2009-09-30 13:09:27 +0200
commit445b28ce8e9e1b4df1797726c105140e09f18696 (patch)
tree19af03f1e3348ce9929d41fbd05a70d2ec8d825a /configure.ac
parenteb31400248f3da3781e94dd8047eead661b30adc (diff)
downloadarping-445b28ce8e9e1b4df1797726c105140e09f18696.tar.gz
Moved build system around a bit
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index f4c1ee2..507ca57 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3,6 +3,7 @@
AC_PREREQ(2.61)
AC_INIT(arping, 2.08, thomas@habets.pp.se)
+AC_CANONICAL_SYSTEM
AC_CONFIG_SRCDIR([src/arping.c])
AM_INIT_AUTOMAKE
AM_MAINTAINER_MODE
@@ -54,7 +55,18 @@ AC_FUNC_SETVBUF_REVERSED
AC_TYPE_SIGNAL
AC_CHECK_FUNCS([gettimeofday memset select strchr strdup strerror strstr])
+echo $target_os
+case "$target_os" in
+ *linux*)
+ AC_LIBOBJ([findif_linux])
+ ;;
+ *)
+ AC_LIBOBJ([findif_other])
+ ;;
+esac
AC_CONFIG_FILES([Makefile])
+AC_CONFIG_FILES([src/Makefile])
+AC_CONFIG_FILES([doc/Makefile])
AC_OUTPUT
echo "