summaryrefslogtreecommitdiff
path: root/arping-2/configure.in
diff options
context:
space:
mode:
authorThomas Habets <thomas@habets.pp.se>2002-11-03 19:47:58 +0000
committerThomas Habets <thomas@habets.pp.se>2002-11-03 19:47:58 +0000
commita524fe5e882c62e343b15248d5622c0ade8ad472 (patch)
tree907ee448d3a9016e271ed1d673adf8de319bce39 /arping-2/configure.in
parent5f6ee8c6c87558820184524db385e789abd7a924 (diff)
downloadarping-a524fe5e882c62e343b15248d5622c0ade8ad472.tar.gz
.
Diffstat (limited to 'arping-2/configure.in')
-rw-r--r--arping-2/configure.in37
1 files changed, 37 insertions, 0 deletions
diff --git a/arping-2/configure.in b/arping-2/configure.in
new file mode 100644
index 0000000..e083609
--- /dev/null
+++ b/arping-2/configure.in
@@ -0,0 +1,37 @@
+dnl $Id: configure.in 737 2002-11-03 19:47:58Z marvin $
+
+AC_INIT(arping2.c)
+AC_CONFIG_HEADER(config.h)
+
+AC_PROG_CC
+AC_PROG_INSTALL
+
+AC_PROG_GCC_TRADITIONAL
+if test "$GCC" = yes ; then
+ CFLAGS="$CFLAGS -Wall"
+fi
+
+AC_CHECK_HEADERS(net/bpf.h)
+
+AC_MSG_CHECKING(If this is WeirdBSD)
+case `uname -s` in
+ *BSD)
+ AC_DEFINE(HAVE_WEIRD_BSD, 1, [define if you have WeirdBSD])
+ AC_MSG_RESULT(yes)
+ ;;
+ *)
+ AC_MSG_RESULT(no)
+ ;;
+esac
+
+AC_MSG_CHECKING(for explicit size type support)
+AC_TRY_COMPILE(
+ [#include <sys/types.h>],
+ [u_int32_t foo;],
+ AC_DEFINE(HAVE_ESIZE_TYPES, 1, [Define this if your system has u_int32_t and such])
+ AC_MSG_RESULT(yes),
+ AC_MSG_RESULT(no))
+
+AC_PREFIX_DEFAULT(/usr/local)
+
+AC_OUTPUT(config.h)