summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorRyan Bloom <rbb@apache.org>2001-08-21 23:41:35 +0000
committerRyan Bloom <rbb@apache.org>2001-08-21 23:41:35 +0000
commitf8b2c6740590140cf73a521fd9a307c11ffef2f6 (patch)
tree3f2615c636761dcbe254d74de3e11337e752fa1a /configure.in
parent5895fdce9f9941f8081ba92b38060e03ec25b27e (diff)
downloadhttpd-f8b2c6740590140cf73a521fd9a307c11ffef2f6.tar.gz
Allow Apache to use libtool 1.4. In order to do this, we check the
libtool version of the machine, and we add the correct flags to the build. We also had to remove the --disable-shared in order to make this work correctly. git-svn-id: https://svn.apache.org/repos/asf/httpd/httpd/trunk@90479 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in24
1 files changed, 20 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index c6ddf09197..77e71b6461 100644
--- a/configure.in
+++ b/configure.in
@@ -45,11 +45,11 @@ dnl ## Run configure for packages Apache uses
echo $ac_n "${nl}Configuring Apache Portable Runtime library ...${nl}"
-APR_SUBDIR_CONFIG(srclib/apr, "$apache_apr_flags --disable-shared --prefix=$prefix")
+APR_SUBDIR_CONFIG(srclib/apr, "$apache_apr_flags --prefix=$prefix")
echo $ac_n "${nl}Configuring Apache Portable Runtime Utility library...${nl}"
-APR_SUBDIR_CONFIG(srclib/apr-util, "--with-apr=../apr --disable-shared --prefix=$prefix")
+APR_SUBDIR_CONFIG(srclib/apr-util, "--with-apr=../apr --prefix=$prefix")
echo $ac_n "${nl}Configuring PCRE regular expression library ...${nl}"
@@ -103,15 +103,31 @@ case $host in
MK_IMPLIB="emximp"
other_targets="$other_targets os2core"
INSTALL_PROG_FLAGS="-e .exe"
+ SHLTCFLAGS=""
+ LTCFLAGS=""
;;
*)
if test "x$LTFLAGS" = "x"; then
LTFLAGS='--silent'
fi
LIBTOOL='$(SHELL) $(top_builddir)/srclib/apr/libtool $(LTFLAGS)'
- SH_LIBTOOL='$(SHELL) $(top_builddir)/shlibtool $(LTFLAGS)'
+ libtoolversion=`$abs_builddir/srclib/apr/libtool --version`
+ case $libtoolversion in
+ *1.4*)
+ SH_LIBTOOL='$(LIBTOOL)'
+ SHLTCFLAGS="-prefer-pic"
+ LTCFLAGS="-prefer-non-pic -static"
+ ;;
+ *)
+ SH_LIBTOOL='$(SHELL) $(top_builddir)/shlibtool $(LTFLAGS)'
+ SHLTCFLAGS=""
+ LTCFLAGS=""
+ ;;
+ esac
;;
esac
+APACHE_SUBST(SHLTCFLAGS)
+APACHE_SUBST(LTCFLAGS)
case $host in
*-apple-aux3*)
@@ -385,7 +401,7 @@ case $host in
;;
esac
-AC_OUTPUT($APACHE_OUTPUT_FILES support/apxs support/apachectl support/dbmmanage support/log_server_status support/logresolve.pl support/phf_abuse_log.cgi support/split-logfile,,[
+AC_OUTPUT($APACHE_OUTPUT_FILES support/apxs support/apachectl support/dbmmanage support/log_server_status support/logresolve.pl support/phf_abuse_log.cgi support/split-logfile build/rules.mk,,[
APACHE_GEN_MAKEFILES
])