summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorRoy T. Fielding <fielding@apache.org>2001-05-12 01:37:27 +0000
committerRoy T. Fielding <fielding@apache.org>2001-05-12 01:37:27 +0000
commitedc5f431abe7a46894a0e6f8bc022bf5b5736122 (patch)
tree5ba9eebf03acd606c1c25eba03c939fdd279e89e /configure.in
parentf5aba03766fb551cf148db74273fa21505d99bdb (diff)
downloadhttpd-edc5f431abe7a46894a0e6f8bc022bf5b5736122.tar.gz
It is easier to re-run configure's test and pick up the cached values
than it is to replicate them in our own macros. This isn't too expensive because CC and CPP have already been set by APR. Too bad it generates a lot of output. Also, we don't need to repeat command-line options that are already being handled by APR now that we use APR's generated flags. The switches are still usable on the command-line. git-svn-id: https://svn.apache.org/repos/asf/httpd/httpd/trunk@89092 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in15
1 files changed, 4 insertions, 11 deletions
diff --git a/configure.in b/configure.in
index c1624f994b..c5bec2f6ad 100644
--- a/configure.in
+++ b/configure.in
@@ -148,6 +148,8 @@ dnl ## Check for programs
AC_PATH_PROG(RM, rm)
AC_PROG_AWK
+AC_PROG_CC
+AC_PROG_CPP
AC_PROG_INSTALL
AC_PROG_LN_S
AC_CHECK_TOOL(RANLIB, ranlib, true)
@@ -155,6 +157,7 @@ dnl AC_PATH_PROG(PERL_PATH, perl)
dnl various OS checks that apparently set required flags
AC_AIX
+AC_ISC_POSIX
AC_MINIX
dnl ## Check for libraries
@@ -201,18 +204,8 @@ AC_ARG_WITH(port,[ --with-port=PORT Port on which to listen (default is
[if test "$withval" = "yes"; then AC_MSG_ERROR('option --with-port requires a value (the TCP port number)'); else PORT="$withval"; fi],
[PORT=80])
-AC_ARG_ENABLE(debug,[ --enable-debug Turn on debugging and compile time warnings],
- [APR_ADDTO(CFLAGS,-g)
- if test $ac_cv_prog_gcc = yes; then
- APR_ADDTO(CFLAGS,-Wall)
- fi
-])dnl
-
AC_ARG_ENABLE(maintainer-mode,[ --enable-maintainer-mode Turn on debugging and compile time warnings],
- [APR_ADDTO(CFLAGS,-g)
- if test $ac_cv_prog_gcc = yes; then
- APR_ADDTO(CFLAGS,[-Wall -Wmissing-prototypes -Wstrict-prototypes -Wmissing-declarations -DAP_DEBUG])
- fi
+ [APR_ADDTO(CPPFLAGS,-DAP_DEBUG)
])dnl
APACHE_ENABLE_LAYOUT