summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorVictor J. Orlikowski <orlikowski@apache.org>2001-06-07 10:03:29 +0000
committerVictor J. Orlikowski <orlikowski@apache.org>2001-06-07 10:03:29 +0000
commitd3feaed25f52d4fa04e125366c77cf1f0edca306 (patch)
tree9495594a700a6710104e4f16d9e227cc9ec8a38d /configure.in
parent54666fc1790460f13ff26791a47221121bdccff8 (diff)
downloadhttpd-d3feaed25f52d4fa04e125366c77cf1f0edca306.tar.gz
Generate httpd.exp on the fly.
This should allow DSOs to work on AIX, without the headache of maintaining the httpd.exp file. This is adapted from OS/2's generation of ApacheCoreOS2.def. There exist a few bugs still: 1) mod_dav and mod_proxy may not yet work, due to certain namespace issues. 2) Some symbols may need to be added, a la core_header.def Once these have been fixed, the old httpd.exp file will be deleted. git-svn-id: https://svn.apache.org/repos/asf/httpd/httpd/trunk@89288 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 23cfb9fd1a..ac69a1f46e 100644
--- a/configure.in
+++ b/configure.in
@@ -234,8 +234,8 @@ if test "$apache_need_shared" = "yes"; then
$SHELL $ac_aux_dir/ltconfig --output=shlibtool --disable-static --srcdir=$ac_aux_dir --cache-file=./config.cache $ac_aux_dir/ltmain.sh
case "$host" in
*-ibm-aix*)
- HTTPD_LDFLAGS="$HTTPD_LDFLAGS -Wl,-bE:$abs_srcdir/support/httpd.exp"
- SH_LDFLAGS="$SH_LDFLAGS -Wl,-bI:$abs_srcdir/support/httpd.exp"
+ HTTPD_LDFLAGS="$HTTPD_LDFLAGS -Wl,-bE:$abs_srcdir/server/httpd.exp"
+ SH_LDFLAGS="$SH_LDFLAGS -Wl,-bI:$abs_srcdir/server/httpd.exp"
;;
*beos)
SH_LDFLAGS='$(top_builddir)/_APP_'