summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorRoy T. Fielding <fielding@apache.org>2001-05-12 03:48:31 +0000
committerRoy T. Fielding <fielding@apache.org>2001-05-12 03:48:31 +0000
commit8ea5039bdbfa2ff0c13fc9d51c02002cd734c57f (patch)
tree105038656e66ad51c551f18c085d360c4a75ff33 /configure.in
parentedc5f431abe7a46894a0e6f8bc022bf5b5736122 (diff)
downloadhttpd-8ea5039bdbfa2ff0c13fc9d51c02002cd734c57f.tar.gz
Fix httpd's definition of LTFLAGS to be consistent with that of apr
and apr-util, allow it to be overridden by the configure command-line (default="--silent") and introduce LT_LDFLAGS to replace what we were formally abusing as LTFLAGS. git-svn-id: https://svn.apache.org/repos/asf/httpd/httpd/trunk@89094 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in7
1 files changed, 5 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index c5bec2f6ad..3f08b1ad84 100644
--- a/configure.in
+++ b/configure.in
@@ -103,8 +103,11 @@ case "$host_alias" in
other_targets="$other_targets os2core"
;;
*)
- LIBTOOL='$(SHELL) $(top_builddir)/srclib/apr/libtool --silent'
- SH_LIBTOOL='$(SHELL) $(top_builddir)/shlibtool --silent'
+ if test "x$LTFLAGS" = "x"; then
+ LTFLAGS='--silent'
+ fi
+ LIBTOOL='$(SHELL) $(top_builddir)/srclib/apr/libtool $(LTFLAGS)'
+ SH_LIBTOOL='$(SHELL) $(top_builddir)/shlibtool $(LTFLAGS)'
;;
esac