summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorGreg Stein <gstein@apache.org>2000-11-26 13:43:32 +0000
committerGreg Stein <gstein@apache.org>2000-11-26 13:43:32 +0000
commit5ab185a99767d89d56446ff518a5c82292867ae9 (patch)
treecc0a5bc9c864191998228f60436788b7b511bd6e /configure.in
parentead2dae94c0560d822962a93a603b391b465f901 (diff)
downloadhttpd-5ab185a99767d89d56446ff518a5c82292867ae9.tar.gz
Start the oft-discussed, but oft-punted lib/aputil library. Drop in a first
cut at an "any" DBM set of cover functions. git-svn-id: https://svn.apache.org/repos/asf/httpd/httpd/trunk@87081 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in7
1 files changed, 4 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index abdaf3062b..4dec8d8c1d 100644
--- a/configure.in
+++ b/configure.in
@@ -167,8 +167,8 @@ dnl ### util_xml is always included, so we always need Expat (for now)
apache_need_expat=yes
dnl AP_LIB_DIRS specifies the additional libs from src/lib/ that we need
-dnl AP_LIBS specifies the actual libraries. note we have two required libs.
-AP_LIBS="lib/apr/\$(LIBPRE)apr.a lib/pcre/libpcre.la"
+dnl AP_LIBS specifies the actual libraries. note we have some required libs.
+AP_LIBS="lib/apr/\$(LIBPRE)apr.a lib/pcre/libpcre.la lib/aputil/libaputil.la"
if test "$apache_need_sdbm" = "yes"; then
AP_LIB_DIRS="$AP_LIB_DIRS sdbm"
AP_LIBS="$AP_LIBS lib/sdbm/libsdbm.la"
@@ -199,7 +199,8 @@ else
fi
APACHE_FAST_OUTPUT(Makefile ap/Makefile lib/Makefile main/Makefile)
-APACHE_FAST_OUTPUT(modules/Makefile os/Makefile support/Makefile lib/pcre/Makefile)
+APACHE_FAST_OUTPUT(modules/Makefile os/Makefile support/Makefile)
+APACHE_FAST_OUTPUT(lib/pcre/Makefile lib/aputil/Makefile)
for i in $AP_LIB_DIRS; do
APACHE_FAST_OUTPUT(lib/$i/Makefile)
done