summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorStefan Fritsch <sf@apache.org>2011-06-22 20:22:24 +0000
committerStefan Fritsch <sf@apache.org>2011-06-22 20:22:24 +0000
commitbde65f90cb59c4116e5c86f9573fe414835fd395 (patch)
tree02f66e4eb22e4236a05eb3875ecba4834307baa8 /configure.in
parentabb02e83c2c941e1be01cb2d67616f622806b336 (diff)
downloadhttpd-bde65f90cb59c4116e5c86f9573fe414835fd395.tar.gz
Add support to ErrorLogFormat for logging the system unique
thread id under Linux git-svn-id: https://svn.apache.org/repos/asf/httpd/httpd/trunk@1138616 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 891e26696a..dcb3e9dc80 100644
--- a/configure.in
+++ b/configure.in
@@ -446,6 +446,18 @@ fopen64
dnl confirm that a void pointer is large enough to store a long integer
APACHE_CHECK_VOID_PTR_LEN
+AC_CACHE_CHECK([for gettid()], ac_cv_gettid,
+[AC_TRY_RUN(#define _GNU_SOURCE
+#include <unistd.h>
+#include <sys/syscall.h>
+#include <sys/types.h>
+int main(int argc, char **argv) {
+pid_t t = syscall(SYS_gettid); return t == -1 ? 1 : 0; },
+[ac_cv_gettid=yes], [ac_cv_gettid=no], [ac_cv_gettid=no])])
+if test "$ac_cv_gettid" = "yes"; then
+ AC_DEFINE(HAVE_GETTID, 1, [Define if you have gettid()])
+fi
+
dnl check for LDAP support, needed by modules/aaa and modules/ldap
AP_FIND_LDAP