summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorJoe Orton <jorton@apache.org>2020-02-03 07:56:05 +0000
committerJoe Orton <jorton@apache.org>2020-02-03 07:56:05 +0000
commitef8172c7f06f2fe137079061f2472bb03c142de8 (patch)
tree488e9c5601026cff0b470ecb7e5379c7c0de5620 /configure.in
parentb3afcc1f595418e70d5b4c1d7eeacc33f91570c0 (diff)
downloadhttpd-ef8172c7f06f2fe137079061f2472bb03c142de8.tar.gz
Merge r1393976, r1393997, r1484554, r1528032, r1528034, r1614821, r1618579, r1618588, r1802251, r1840554, r1840555, r1872761, r1872763 from trunk:
* modules/arch/unix/mod_systemd.c: New module. Submitted by: Jan Kaluza <jkaluza redhat.com> * modules/arch/unix/mod_systemd.c (systemd_pre_mpm): Simplify code slightly; no functional change. Use AP_DECLARE_MODULE. * configure.in: Simplify/fix systemd detection: move later to fix autoconf warnings; define HAVE_SYSTEMD rather than using CPPFLAGS. * server/listen.c: Use HAVE_SYSTEMD for systemd #define. * modules/arch/unix/config5.m4: Update systemd headers check. Don't link support/* against systemd libs. * Makefile.in: Link httpd using $(HTTPD_LIBS). * configure.in: Add systemd to HTTPD_LIBS rather than LIBS. Add PCRE libs to HTTPD_LIBS. * configure.in, acinclude.m4: Move systemd check to APACHE_CHECK_SYSTEMD and use pkg-config where available. mod_systemd: Add IdleShutdown - number of seconds in idle-state after which httpd is shutdown. This is useful in a combination with socket activation. Add mod_systemd documentation. mod_systemd: Use AP_SIG_GRACEFUL instead of SIGWINCH. Fix overriding ExtendedStatus to "off" with mod_systemd loaded, and give more feedback to systemd during a reload. * modules/arch/unix/mod_systemd.c (systemd_pre_config): New function; tell systemd the service is reloading here. (systemd_pre_mpm): Don't set ap_extended_status here, do nothing if ExtendedStatus is off. (register_hooks): Register pre_config hook. * modules/arch/unix/mod_systemd.c (systemd_post_config): Fix systemd service getting stuck reloading if "ExtendedStatus off" is configured; regression in r1802251. PR: 62697 * modules/arch/unix/mod_systemd.c (systemd_pre_mpm, systemd_monitor): Ignore sd_notify{,f} failure cases as currently recommended by the systemd API docs. * modules/arch/unix/mod_systemd.c: Remove IdleShutdown feature which was buggy per sf's feedback in 2.4.x backport proposal, and would probably be more appropriate outside this module anyway. * modules/arch/unix/config5.m4: Don't override enable_systemd, fixing --enable-systemd=static per covener's suggestion in <CALK=YjPrN644NtLROwYPyBeCpev-GHSAD2J-Z2hupLymZ0op-g@mail.gmail.com> Also fix the APACHE_MODULE() usage; disable the module by default for the "all" modules selection. PR: 57632 Submitted by: jkaluza, jorton, nd Reviewed by: jorton, jim, elukey git-svn-id: https://svn.apache.org/repos/asf/httpd/httpd/branches/2.4.x@1873519 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 9feacebf98..f8f9442bad 100644
--- a/configure.in
+++ b/configure.in
@@ -504,6 +504,8 @@ if test "$ac_cv_struct_tm_gmtoff" = "yes"; then
AC_DEFINE(HAVE_GMTOFF, 1, [Define if struct tm has a tm_gmtoff field])
fi
+APACHE_CHECK_SYSTEMD
+
dnl ## Set up any appropriate OS-specific environment variables for apachectl
case $host in