summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorJim Jagielski <jim@apache.org>2017-10-17 18:48:24 +0000
committerJim Jagielski <jim@apache.org>2017-10-17 18:48:24 +0000
commite2983e0528a250d4771df791eab2f8c5f4e85f8e (patch)
tree66f5a3e7f468c1b3735a95145f77ffe3570033f2 /configure.in
parent50a1c62f0f6965f9c79b103ccb069d1a6e7d704e (diff)
downloadhttpd-e2983e0528a250d4771df791eab2f8c5f4e85f8e.tar.gz
Merge r1812263, r1812301 from trunk:
Fix maintainer mode with GCC/Clang. Setting -Wstrict-prototypes in combination with -Werror leads to compiler errors during configure checks (autoconf generates incomplete prototypes). Adding -Wno-error=strict-prototypes lets the compiler tolerate those. Possible future enhancement: remember such "configure time only" flags and remove them from CFLAGS before generating our build time files (Makefile, config_vars.mk etc.), so that the full -Werror is in place during building. Follow up to r1812263. As suggested by Joe, add --maintainer/debugger-mode's CFLAGS in NOTEST_CFLAGS to avoid interractions with autoconf's AC_LANG_PROGRAM. APACHE_ADD_GCC_CFLAG now also forces -Wno-strict-prototypes for -Werror to work despite AC_LANG_PROGRAM generating this warning by itself. Submitted by: rjung, ylavic Reviewed by: ylavic, rjung, jim git-svn-id: https://svn.apache.org/repos/asf/httpd/httpd/branches/2.4.x@1812437 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in31
1 files changed, 20 insertions, 11 deletions
diff --git a/configure.in b/configure.in
index 7ae20b83d0..761e836624 100644
--- a/configure.in
+++ b/configure.in
@@ -593,17 +593,21 @@ AC_ARG_ENABLE(load-all-modules,APACHE_HELP_STRING(--enable-load-all-modules,Load
AC_ARG_ENABLE(maintainer-mode,APACHE_HELP_STRING(--enable-maintainer-mode,Turn on debugging and compile time warnings and load all compiled modules),
[
if test "$enableval" = "yes"; then
- APR_ADDTO(CPPFLAGS, -DAP_DEBUG)
+ APR_ADDTO(NOTEST_CPPFLAGS, -DAP_DEBUG)
if test "$GCC" = "yes"; then
- APR_ADDTO(CFLAGS,[-Wall -Wmissing-prototypes -Wstrict-prototypes -Wmissing-declarations -Wpointer-arith])
APACHE_ADD_GCC_CFLAG([-std=c89])
APACHE_ADD_GCC_CFLAG([-Werror])
+ APACHE_ADD_GCC_CFLAG([-Wall])
+ APACHE_ADD_GCC_CFLAG([-Wstrict-prototypes])
+ APACHE_ADD_GCC_CFLAG([-Wmissing-prototypes])
+ APACHE_ADD_GCC_CFLAG([-Wmissing-declarations])
APACHE_ADD_GCC_CFLAG([-Wdeclaration-after-statement])
+ APACHE_ADD_GCC_CFLAG([-Wpointer-arith])
APACHE_ADD_GCC_CFLAG([-Wformat])
APACHE_ADD_GCC_CFLAG([-Wformat-security])
APACHE_ADD_GCC_CFLAG([-Wunused])
elif test "$AIX_XLC" = "yes"; then
- APR_ADDTO(CFLAGS,-qfullpath -qinitauto=FE -qcheck=all -qinfo=pro)
+ APR_ADDTO(NOTEST_CFLAGS,-qfullpath -qinitauto=FE -qcheck=all -qinfo=pro)
fi
if test "x$enable_load_all_modules" = "x"; then
LOAD_ALL_MODULES=yes
@@ -619,16 +623,21 @@ AC_ARG_ENABLE(maintainer-mode,APACHE_HELP_STRING(--enable-maintainer-mode,Turn o
AC_ARG_ENABLE(debugger-mode,APACHE_HELP_STRING(--enable-debugger-mode,Turn on debugging and compile time warnings and turn off optimization),
[
if test "$enableval" = "yes"; then
- APR_ADDTO(CPPFLAGS, -DAP_DEBUG)
+ APR_ADDTO(NOTEST_CPPFLAGS, -DAP_DEBUG)
if test "$GCC" = "yes"; then
- APR_ADDTO(CFLAGS,[-Wall -Wmissing-prototypes -Wstrict-prototypes -Wmissing-declarations -Wpointer-arith -O0])
+ APACHE_ADD_GCC_CFLAG([-O0])
+ APACHE_ADD_GCC_CFLAG([-Wall])
+ APACHE_ADD_GCC_CFLAG([-Wstrict-prototypes])
+ APACHE_ADD_GCC_CFLAG([-Wmissing-prototypes])
+ APACHE_ADD_GCC_CFLAG([-Wmissing-declarations])
APACHE_ADD_GCC_CFLAG([-Wdeclaration-after-statement])
APACHE_ADD_GCC_CFLAG([-Werror=declaration-after-statement])
+ APACHE_ADD_GCC_CFLAG([-Wpointer-arith])
APACHE_ADD_GCC_CFLAG([-Wformat])
APACHE_ADD_GCC_CFLAG([-Wformat-security])
APACHE_ADD_GCC_CFLAG([-Werror=format-security])
elif test "$AIX_XLC" = "yes"; then
- APR_ADDTO(CFLAGS,-qfullpath -qinitauto=FE -qcheck=all -qinfo=pro)
+ APR_ADDTO(NOTEST_CFLAGS,-qfullpath -qinitauto=FE -qcheck=all -qinfo=pro)
fi
fi
])dnl
@@ -810,10 +819,10 @@ AC_MSG_NOTICE([Restore user-defined environment settings...])
AC_MSG_NOTICE([])
APACHE_CONF_SEL_CC=${CC}
-APACHE_CONF_SEL_CFLAGS=${CFLAGS}
-APACHE_CONF_SEL_LDFLAGS=${LDFLAGS}
-APACHE_CONF_SEL_LIBS=${LIBS}
-APACHE_CONF_SEL_CPPFLAGS=${CPPFLAGS}
+APACHE_CONF_SEL_CFLAGS="${CFLAGS} ${EXTRA_CFLAGS} ${NOTEST_CFLAGS}"
+APACHE_CONF_SEL_CPPFLAGS="${CPPFLAGS} ${EXTRA_CPPFLAGS} ${NOTEST_CPPFLAGS}"
+APACHE_CONF_SEL_LDFLAGS="${LDFLAGS} ${EXTRA_LDFLAGS} ${NOTEST_LDFLAGS}"
+APACHE_CONF_SEL_LIBS="${LIBS} ${EXTRA_LIBS} ${NOTEST_LIBS}"
APACHE_CONF_SEL_CPP=${CPP}
APR_RESTORE_THE_ENVIRONMENT(CPPFLAGS, EXTRA_)
@@ -879,8 +888,8 @@ AC_MSG_NOTICE([summary of build options:
Install prefix: ${prefix}
C compiler: ${APACHE_CONF_SEL_CC}
CFLAGS: ${APACHE_CONF_SEL_CFLAGS}
+ CPPFLAGS: ${APACHE_CONF_SEL_CPPFLAGS}
LDFLAGS: ${APACHE_CONF_SEL_LDFLAGS}
LIBS: ${APACHE_CONF_SEL_LIBS}
- CPPFLAGS: ${APACHE_CONF_SEL_CPPFLAGS}
C preprocessor: ${APACHE_CONF_SEL_CPP}
])