summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorRainer Jung <rjung@apache.org>2012-01-31 11:42:32 +0000
committerRainer Jung <rjung@apache.org>2012-01-31 11:42:32 +0000
commitbbe55f7317ef45ec83327bf88f5dca1f0d9ac92d (patch)
treec52d6ce191e5be58527037a406d3a758d5860b17 /configure.in
parenta5b41ccf125549d28d76f8a11acdb54754aef8ad (diff)
downloadhttpd-bbe55f7317ef45ec83327bf88f5dca1f0d9ac92d.tar.gz
configure: Move the --with-included-apr check so that srcdir!=builddir builds
aren't broken by it. Backport of r1232838 from trunk. git-svn-id: https://svn.apache.org/repos/asf/httpd/httpd/branches/2.4.x@1238400 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in20
1 files changed, 10 insertions, 10 deletions
diff --git a/configure.in b/configure.in
index ebad11d463..138c5f2ce9 100644
--- a/configure.in
+++ b/configure.in
@@ -86,9 +86,12 @@ AC_ARG_WITH(included-apr,
APACHE_HELP_STRING(--with-included-apr,Use bundled copies of APR/APR-Util))
if test "x$with_included_apr" = "xyes"; then
- apr_found=reconfig
+ apr_found=reconfig
+ if test ! -d srclib/apr; then
+ AC_MSG_ERROR([Bundled APR requested but not found at srclib/apr. Download and unpack the corresponding httpd-${HTTPD_VERSION}-deps package over this one.])
+ fi
else
- APR_FIND_APR("$srcdir/srclib/apr", "./srclib/apr", 1, 1 2)
+ APR_FIND_APR("$srcdir/srclib/apr", "./srclib/apr", 1, 1 2)
fi
if test "$apr_found" = "no"; then
@@ -96,9 +99,6 @@ if test "$apr_found" = "no"; then
fi
if test "$apr_found" = "reconfig"; then
- if test ! -d srclib/apr; then
- AC_MSG_ERROR([Bundled APR requested but not found at srclib/apr. Download and unpack the corresponding httpd-${HTTPD_VERSION}-deps package over this one.])
- fi
APR_SUBDIR_CONFIG(srclib/apr,
[$apache_apr_flags --prefix=$prefix --exec-prefix=$exec_prefix --libdir=$libdir --includedir=$includedir --bindir=$bindir --datadir=$datadir --with-installbuilddir=$installbuilddir],
[--enable-layout=*|\'--enable-layout=*])
@@ -133,9 +133,12 @@ APR_CONFIG="$APR_BINDIR/apr-${apr_major_version}-config"
echo $ac_n "${nl}Configuring Apache Portable Runtime Utility library...${nl}"
if test "x${apr_major_version}" = "x2"; then
- apu_found=obsolete
+ apu_found=obsolete
elif test "x$with_included_apr" = "xyes"; then
- apu_found=reconfig
+ apu_found=reconfig
+ if test ! -d srclib/apr-util; then
+ AC_MSG_ERROR([Bundled APR-Util requested but not found at srclib/apr-util. Download and unpack the corresponding httpd-${HTTPD_VERSION}-deps package over this one.])
+ fi
else
dnl If httpd is buildconf'ed against an apr 2.x tree, then 1.x
dnl isn't supported.
@@ -160,9 +163,6 @@ yes.reconfig)
esac
if test "$apu_found" = "reconfig"; then
- if test ! -d srclib/apr-util; then
- AC_MSG_ERROR([Bundled APR-Util requested but not found at srclib/apr-util. Download and unpack the corresponding httpd-${HTTPD_VERSION}-deps package over this one.])
- fi
APR_SUBDIR_CONFIG(srclib/apr-util,
[--with-apr=../apr --prefix=$prefix --exec-prefix=$exec_prefix --libdir=$libdir --includedir=$includedir --bindir=$bindir],
[--enable-layout=*|\'--enable-layout=*])