summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorJean-Frederic Clere <jfclere@apache.org>2011-04-12 09:09:52 +0000
committerJean-Frederic Clere <jfclere@apache.org>2011-04-12 09:09:52 +0000
commitb69191e95b9fb94acf8adac5b67cbd3c02e64aa3 (patch)
tree0e3ae5e21952d7a966e0416a9dd1ed417716c255 /configure.in
parent4fd1d0eb42b958f725f8d81c9bebcc2ea20efdd8 (diff)
downloadhttpd-b69191e95b9fb94acf8adac5b67cbd3c02e64aa3.tar.gz
Allow apr and apr-util to be in 2 different location.
Otherwise: apr_version.h is not found when apr-util is tested. git-svn-id: https://svn.apache.org/repos/asf/httpd/httpd/trunk@1091330 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in10
1 files changed, 9 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 6539f40cf7..8afe224cbe 100644
--- a/configure.in
+++ b/configure.in
@@ -367,7 +367,15 @@ fi
if test "${apu_found}" = "yes"; then
# Require at least APR-util 1.3.x otherwise fail
- APACHE_CHECK_APxVER([apu], 1, 3)
+ if test "${apr_found}" = "yes"; then
+ # we need to add the APR includes to CPPFLAGS
+ apu_ckver_CPPFLAGS="$CPPFLAGS"
+ CPPFLAGS="$CPPFLAGS `$apr_config --includes`"
+ APACHE_CHECK_APxVER([apu], 1, 3)
+ CPPFLAGS="$apu_ckver_CPPFLAGS"
+ else
+ APACHE_CHECK_APxVER([apu], 1, 3)
+ fi
fi
dnl Check for what we can generate dependency files with