summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorJeff Trawick <trawick@apache.org>2003-03-08 13:54:41 +0000
committerJeff Trawick <trawick@apache.org>2003-03-08 13:54:41 +0000
commita2d2ae5a57e040411e4375ab9ad586a959e96f8f (patch)
tree65159da0f341112348fd53aba432eb721fda9e44 /configure.in
parent481c8dd84555d4a6665319642b300fc55a3e0989 (diff)
downloadhttpd-a2d2ae5a57e040411e4375ab9ad586a959e96f8f.tar.gz
use APR_CHECK_APR_DEFINE() where possible
git-svn-id: https://svn.apache.org/repos/asf/httpd/httpd/trunk@98947 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in13
1 files changed, 3 insertions, 10 deletions
diff --git a/configure.in b/configure.in
index 1a799433aa..1bd3d20ac8 100644
--- a/configure.in
+++ b/configure.in
@@ -330,14 +330,7 @@ AC_ARG_WITH(port,APACHE_HELP_STRING(--with-port=PORT,Port on which to listen (de
[if test "$withval" = "yes"; then AC_MSG_ERROR('option --with-port requires a value (the TCP port number)'); else PORT="$withval"; fi],
[PORT=80])
-dnl ## See if APR has IPv6 support
-ap_old_cppflags=$CPPFLAGS
-CPPFLAGS="$CPPFLAGS $INCLUDES"
-AC_TRY_COMPILE([#include <apr.h>], [
-#if !APR_HAVE_IPV6
-#error APR does not have IPv6 support
-#endif], apr_have_ipv6=yes, apr_have_ipv6=no)
-CPPFLAGS=$ap_old_cppflags
+APR_CHECK_APR_DEFINE(APR_HAVE_IPV6)
AC_ARG_ENABLE(v4-mapped,APACHE_HELP_STRING(--enable-v4-mapped,Allow IPv6 sockets to handle IPv4 connections),
[
@@ -354,10 +347,10 @@ AC_ARG_ENABLE(v4-mapped,APACHE_HELP_STRING(--enable-v4-mapped,Allow IPv6 sockets
esac
])
-if test $v4mapped = "yes" -o $apr_have_ipv6 = "no"; then
+if test $v4mapped = "yes" -o $ac_cv_define_APR_HAVE_IPV6 = "no"; then
nonssl_listen_stmt_1=""
nonssl_listen_stmt_2="Listen @@Port@@"
- if test $apr_have_ipv6 = "yes"; then
+ if test $ac_cv_define_APR_HAVE_IPV6 = "yes"; then
AC_DEFINE(AP_ENABLE_V4_MAPPED, 1,
[Allow IPv4 connections on IPv6 listening sockets])
fi