summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorRainer Jung <rjung@apache.org>2012-02-13 20:02:01 +0000
committerRainer Jung <rjung@apache.org>2012-02-13 20:02:01 +0000
commit69a1a19a3fbd1d5bbac82b42fb69c60b4c2bed03 (patch)
tree5f5ef1bbc5f96e3e5b78bb1ec734c9dd6ead3e84 /configure.in
parent6ab9c0d5c969625fc5480d744b122f01ea079cee (diff)
downloadhttpd-69a1a19a3fbd1d5bbac82b42fb69c60b4c2bed03.tar.gz
Fix out of tree build using apr and apr-util in srclib.
Also rephrase remaining mentioning of the deps package. git-svn-id: https://svn.apache.org/repos/asf/httpd/httpd/branches/2.4.x@1243670 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index 326b8bb5be..9f960963ae 100644
--- a/configure.in
+++ b/configure.in
@@ -87,7 +87,7 @@ APACHE_HELP_STRING(--with-included-apr,Use bundled copies of APR/APR-Util))
if test "x$with_included_apr" = "xyes"; then
apr_found=reconfig
- if test ! -d srclib/apr; then
+ if test ! -d srclib/apr && ! -d $srcdir/srclib/apr; then
AC_MSG_ERROR([Bundled APR requested but not found at ./srclib/. Download and unpack the corresponding apr and apr-util packages to ./srclib/.])
fi
else
@@ -136,8 +136,8 @@ if test "x${apr_major_version}" = "x2"; then
apu_found=obsolete
elif test "x$with_included_apr" = "xyes"; then
apu_found=reconfig
- if test ! -d srclib/apr-util; then
- AC_MSG_ERROR([Bundled APR-Util requested but not found at srclib/apr-util. Download and unpack the corresponding httpd-${HTTPD_VERSION}-deps package over this one.])
+ if test ! -d srclib/apr-util && ! -d $srcdir/srclib/apr-util; then
+ AC_MSG_ERROR([Bundled APR-Util requested but not found at ./srclib/. Download and unpack the corresponding apr and apr-util packages to ./srclib/.])
fi
else
dnl If httpd is buildconf'ed against an apr 2.x tree, then 1.x