summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorWilfredo Sanchez <wsanchez@apache.org>2002-11-29 07:23:57 +0000
committerWilfredo Sanchez <wsanchez@apache.org>2002-11-29 07:23:57 +0000
commit267897271322e79a14c630de21da2ef7756e567e (patch)
tree4d657804a4c2b1e58ead92f4cadd1074c872556c /configure.in
parent9018dc55c1105a8df2d5b848cbd7eeacb91517d1 (diff)
downloadhttpd-267897271322e79a14c630de21da2ef7756e567e.tar.gz
If apr and apr-util are not in-tree, we need to be able to find the
include directory for each in order to generate the server/exports.c and server/export_vars.h files. configure.in: - Provide APR_INCLUDEDIR, APU_INCLUDEDIR. server/Makefile.in: - Use $APR_INCLUDEDIR $APU_INCLUDEDIR vars. - Add export_files target to generate a list of headers with symbols to export, use that list to generate exports.c and export_vars.h. git-svn-id: https://svn.apache.org/repos/asf/httpd/httpd/trunk@97673 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 6a18a3df98..60e9e03699 100644
--- a/configure.in
+++ b/configure.in
@@ -80,6 +80,7 @@ APR_ADDTO(LDFLAGS, `$apr_config --ldflags`)
APR_ADDTO(INCLUDES, `$apr_config --includes`)
SHLIBPATH_VAR=`$apr_config --shlib-path-var`
APR_BINDIR=`$apr_config --bindir`
+APR_INCLUDEDIR=`$apr_config --includes | sed 's|^.*-I\([[^ ]]*apr[[^ ]]*\).*$|\1|'`
echo $ac_n "${nl}Configuring Apache Portable Runtime Utility library...${nl}"
@@ -99,6 +100,7 @@ fi
APR_ADDTO(LDFLAGS, `$apu_config --ldflags`)
APR_ADDTO(INCLUDES, `$apu_config --includes`)
APU_BINDIR=`$apu_config --bindir`
+APU_INCLUDEDIR=`$apu_config --includes | sed 's|^.*-I\([[^ ]]*apr[[^ ]]*\).*$|\1|'`
echo $ac_n "${nl}Configuring PCRE regular expression library ...${nl}"