summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorJeff Trawick <trawick@apache.org>2002-06-14 16:38:07 +0000
committerJeff Trawick <trawick@apache.org>2002-06-14 16:38:07 +0000
commit1f8c9494433c4a7a1ba5816bb3fc0840063744de (patch)
tree76c46824ba66f6618ee0756329c2452952df389a /configure.in
parent62cb8e15068e0cb41b419a1a9b790c3e7de448f3 (diff)
downloadhttpd-1f8c9494433c4a7a1ba5816bb3fc0840063744de.tar.gz
AIX 4.3.3 and above: Define SINGLE_LISTEN_UNSERIALIZED_ACCEPT.
These levels of AIX don't have a thundering herd problem with accept(). git-svn-id: https://svn.apache.org/repos/asf/httpd/httpd/trunk@95673 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 306bf587a5..f2d66df25f 100644
--- a/configure.in
+++ b/configure.in
@@ -208,6 +208,12 @@ case $host in
APR_SETVAR(APACHE_MPM, [prefork])
APR_SETVAR(SINGLE_LISTEN_UNSERIALIZED_ACCEPT, [1])
;;
+ *aix*)
+ aixver=`echo $host | sed 's/^[[^0-9]]*//' | sed 's/\.//g'`
+ if test $aixver -ge 4330; then
+ APR_SETVAR(SINGLE_LISTEN_UNSERIALIZED_ACCEPT, [1])
+ fi
+ ;;
esac
dnl