summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py20
1 files changed, 2 insertions, 18 deletions
diff --git a/setup.py b/setup.py
index 872dbefadb..fd3fb0a8a3 100644
--- a/setup.py
+++ b/setup.py
@@ -7,7 +7,7 @@ from glob import glob
sys.path.insert(0, os.path.abspath('lib'))
from ansible import __version__, __author__
try:
- from setuptools import setup
+ from setuptools import setup, find_packages
except ImportError:
print "Ansible now needs setuptools in order to build. " \
"Install it using your package manager (usually python-setuptools) or via pip (pip install setuptools)."
@@ -22,23 +22,7 @@ setup(name='ansible',
license='GPLv3',
install_requires=['paramiko', 'jinja2', "PyYAML", 'setuptools', 'pycrypto >= 2.6'],
package_dir={ 'ansible': 'lib/ansible' },
- packages=[
- 'ansible',
- 'ansible.cache',
- 'ansible.utils',
- 'ansible.utils.module_docs_fragments',
- 'ansible.inventory',
- 'ansible.inventory.vars_plugins',
- 'ansible.playbook',
- 'ansible.runner',
- 'ansible.runner.action_plugins',
- 'ansible.runner.lookup_plugins',
- 'ansible.runner.connection_plugins',
- 'ansible.runner.shell_plugins',
- 'ansible.runner.filter_plugins',
- 'ansible.callback_plugins',
- 'ansible.module_utils'
- ],
+ packages=find_packages('lib'),
package_data={
'': ['module_utils/*.ps1'],
},