summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorBrian Coca <bcoca@users.noreply.github.com>2017-08-15 16:38:59 -0400
committerGitHub <noreply@github.com>2017-08-15 16:38:59 -0400
commitf921369445900dcc756821e40c9257d5359087af (patch)
tree173a768f8dddfce15c4471479d3677fbe1b51cff /setup.py
parent8b617aaef564052d05c41e033f7d166570d660b1 (diff)
downloadansible-f921369445900dcc756821e40c9257d5359087af.tar.gz
Ansible Config part2 (#27448)
* Ansible Config part2 - made dump_me nicer, added note this is not prod - moved internal key removal function to vars - carry tracebacks in errors we can now show tracebacks for plugins on vvv - show inventory plugin tracebacks on vvv - minor fixes to cg groups plugin - draft config from plugin docs - made search path warning 'saner' (top level dirs only) - correctly display config entries and others - removed unneeded code - commented out some conn plugin specific from base.yml - also deprecated sudo/su - updated ssh conn docs - shared get option method for connection plugins - note about needing eval for defaults - tailored yaml ext - updated strategy entry - for connection pliugins, options load on plugin load - allow for long types in definitions - better display in ansible-doc - cleaned up/updated source docs and base.yml - added many descriptions - deprecated include toggles as include is - draft backwards compat get_config - fixes to ansible-config, added --only-changed - some code reoorg - small license headers - show default in doc type - pushed module utils details to 5vs - work w/o config file - PEPE ATE! - moved loader to it's own file - fixed rhn_register test - fixed boto requirement in make tests - I ate Pepe - fixed dynamic eval of defaults - better doc code skip ipaddr filter tests when missing netaddr removed devnull string from config better becoem resolution * killed extra space with extreeme prejudice cause its an affront against all that is holy that 2 spaces touch each other! shippable timing out on some images, but merging as it passes most
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py3
1 files changed, 1 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 0262b7d3ef..4345e4206e 100644
--- a/setup.py
+++ b/setup.py
@@ -190,8 +190,7 @@ setup(
'galaxy/data/*/*/.*',
'galaxy/data/*/*/*.*',
'galaxy/data/*/tests/inventory',
- 'config/data/*.yaml',
- 'config/data/*.yml',
+ 'config/base.yml',
],
},
classifiers=[