summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorAlan Rominger <arominge@redhat.com>2017-10-27 12:47:45 -0400
committeransibot <ansibot@users.noreply.github.com>2017-10-27 12:47:45 -0400
commitef42eaeaa1d463eae5c4788f9a35cd3d24580d92 (patch)
treef7a9e9bfe50a848876fc6b9666c8267bed52319e /setup.py
parente010fcf7e12a2ec2ff561235d036052198ff174a (diff)
downloadansible-ef42eaeaa1d463eae5c4788f9a35cd3d24580d92.tar.gz
set the zip_safe flag to False (#32194)
The references to __file__ within code base make the zip_safe method of installing not possible.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py4
1 files changed, 3 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index c934a2f4fd..cef77ba1bc 100644
--- a/setup.py
+++ b/setup.py
@@ -220,5 +220,7 @@ setup(
'bin/ansible-vault',
],
data_files=[],
- extras_require=extra_requirements
+ extras_require=extra_requirements,
+ # Installing as zip files would break due to references to __file__
+ zip_safe=False
)