summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorMatt Davis <nitzmahone@users.noreply.github.com>2017-07-31 12:16:26 -0700
committerGitHub <noreply@github.com>2017-07-31 12:16:26 -0700
commitdae8857d3da88994a321e7bb9e0972880a6c3840 (patch)
tree75dfb7c447e86e075b6bd9068b70abaf75fc4aca /setup.py
parentbc3c315bc8ffac677cbba74ea067ef069d920172 (diff)
downloadansible-dae8857d3da88994a321e7bb9e0972880a6c3840.tar.gz
powershell setup fixes (#27516)
* fixes #27374 * recursively include top 2 levels of .psm1's under module_utils/powershell * recursively include top 2 levels of .ps1's under modules/windows (for future restructuring)
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py5
1 files changed, 3 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index c741c568a4..89fffa5895 100644
--- a/setup.py
+++ b/setup.py
@@ -172,9 +172,10 @@ setup(
packages=find_packages('lib'),
package_data={
'': [
- 'module_utils/*.ps1',
- 'modules/windows/*.ps1',
+ 'module_utils/powershell/*.psm1',
+ 'module_utils/powershell/*/*.psm1',
'modules/windows/*.ps1',
+ 'modules/windows/*/*.ps1',
'galaxy/data/*/*.*',
'galaxy/data/*/*/.*',
'galaxy/data/*/*/*.*',