summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorToshio Kuratomi <toshio@fedoraproject.org>2015-10-15 17:55:23 -0700
committerToshio Kuratomi <toshio@fedoraproject.org>2015-10-16 08:21:28 -0700
commitbaa309309d4041678bac4352da62a3b555b4fd49 (patch)
treecb863a297bb37d9beac11a850ca0f8c785f55f71 /setup.py
parent28c933ce5eff7de7f9fea538f52620d7a86b9895 (diff)
downloadansible-baa309309d4041678bac4352da62a3b555b4fd49.tar.gz
Bundle a new version of python-six for compatibility along with some code to make it easy for distributions to override the bunndled copy if they have a new enough version.six-compat
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py4
1 files changed, 3 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 7ada3f7f97..f174f979f8 100644
--- a/setup.py
+++ b/setup.py
@@ -20,7 +20,9 @@ setup(name='ansible',
author_email='support@ansible.com',
url='http://ansible.com/',
license='GPLv3',
- install_requires=['paramiko', 'jinja2', "PyYAML", 'setuptools', 'pycrypto >= 2.6', 'six'],
+ # Ansible will also make use of a system copy of python-six if installed but use a
+ # Bundled copy if it's not.
+ install_requires=['paramiko', 'jinja2', "PyYAML", 'setuptools', 'pycrypto >= 2.6'],
package_dir={ '': 'lib' },
packages=find_packages('lib'),
package_data={