summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorbillwanjohi <kaguru@gmail.com>2014-09-11 22:47:30 +0000
committerbillwanjohi <kaguru@gmail.com>2015-07-27 19:33:54 +0000
commitb2739cec6d22160d162a04a41d8ea68d8c669050 (patch)
tree9dd2fe8572b31d2cee95060dfee3c339add3825d /setup.py
parent7d8afad28c46ec04e6a32d5aff65bde2d5ab54c5 (diff)
downloadansible-b2739cec6d22160d162a04a41d8ea68d8c669050.tar.gz
add distutils package classifiers
I was particularly interested in the programming language ones, but the others might be useful to others browsing PyPI. Now with GPLv3+, and Utilities topic.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py15
1 files changed, 15 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 513108f0d6..60c7d73ffc 100644
--- a/setup.py
+++ b/setup.py
@@ -26,6 +26,21 @@ setup(name='ansible',
package_data={
'': ['module_utils/*.ps1', 'modules/core/windows/*.ps1', 'modules/extras/windows/*.ps1'],
},
+ classifiers=[
+ 'Development Status :: 5 - Production/Stable',
+ 'Environment :: Console',
+ 'Intended Audience :: Developers',
+ 'Intended Audience :: Information Technology',
+ 'Intended Audience :: System Administrators',
+ 'License :: OSI Approved :: GNU General Public License v3 or later (GPLv3+)',
+ 'Natural Language :: English',
+ 'Operating System :: POSIX',
+ 'Programming Language :: Python :: 2.6',
+ 'Programming Language :: Python :: 2.7',
+ 'Topic :: System :: Installation/Setup',
+ 'Topic :: System :: Systems Administration',
+ 'Topic :: Utilities',
+ ],
scripts=[
'bin/ansible',
'bin/ansible-playbook',