summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorMatt Martz <matt@sivel.net>2019-07-24 13:58:13 -0500
committerGitHub <noreply@github.com>2019-07-24 13:58:13 -0500
commit95f4282c42cd5ffe4a19a1122685ae9c31876a12 (patch)
treef2fa2d226ce0d55f7fb5b84cfade886bc23cf63b /setup.py
parent119f2b873a863d05d38a29599ade2ac09f8c6f01 (diff)
downloadansible-95f4282c42cd5ffe4a19a1122685ae9c31876a12.tar.gz
Verify package data in setup.py installs all files (#59537)
* Add sanity test to ensure all non-py files are installed * Fix mode and regex * Fix role skel inventory package_data * Add docs * Update package_data for inventory files * Address pylint concerns * Another tweak to package_data * Address review feedback * Change index to 1 * add to ansible-only.txt
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py1
1 files changed, 1 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 5b4650e16e..c607de5fa8 100644
--- a/setup.py
+++ b/setup.py
@@ -271,6 +271,7 @@ static_setup_params = dict(
'galaxy/data/*/*/.*',
'galaxy/data/*/*/*.*',
'galaxy/data/*/tests/inventory',
+ 'galaxy/data/*/role/tests/inventory',
'config/base.yml',
'config/module_defaults.yml',
],