summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorBrian Coca <bcoca@users.noreply.github.com>2017-06-14 11:08:34 -0400
committerGitHub <noreply@github.com>2017-06-14 11:08:34 -0400
commit74842adc07edb248f9b544389ce4093b9149f195 (patch)
tree38e247fb9b033a0bf4ead48cf012d23c9fb455c4 /setup.py
parent4344132a7d094cd365fa8cb0871ad79aca185517 (diff)
downloadansible-74842adc07edb248f9b544389ce4093b9149f195.tar.gz
1st part of ansible config, adds ansible-config to view/manage configs (#12797)
* Start of ansible config project moved configuration definitions to external yaml file vs hardcoded * updated constants to be a data strcutures that are looped over and also return origin of setting changed to manager/data scheme for base classes new cli ansible-config to view/manage ansible configuration settings * prints green for default/unchanged and yellow for those that have been overriden * added list action to show all configurable settings and their associated ini and env var names * allows specifying config file to see what result would look like * TBD update, edit and view options removed test for functions that have been removed env_Vars are now list of dicts allows for version_added and deprecation in future added a couple of descriptions for future doc autogeneration ensure test does not fail if delete_me exists normalized 'path expansion' added yaml config to setup packaging removed unused imports better encoding handling updated as per feedback * pep8
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py4
1 files changed, 3 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index d43fd299ff..58f65b6039 100644
--- a/setup.py
+++ b/setup.py
@@ -69,7 +69,9 @@ setup(
'galaxy/data/*/*.*',
'galaxy/data/*/*/.*',
'galaxy/data/*/*/*.*',
- 'galaxy/data/*/tests/inventory'
+ 'galaxy/data/*/tests/inventory',
+ 'config/data/*.yaml',
+ 'config/data/*.yml',
],
},
classifiers=[