summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorAdrian Likins <alikins@redhat.com>2017-05-09 09:57:30 -0400
committerGitHub <noreply@github.com>2017-05-09 09:57:30 -0400
commit6f2cd64cff48c88903432edbb64ef08734e7d8ea (patch)
treee4cea054d58635bda24116b8cae3d58aa7e7f52b /setup.py
parent5b3ea6562b535fdb24b836afbe11cbcfafa4ee02 (diff)
downloadansible-6f2cd64cff48c88903432edbb64ef08734e7d8ea.tar.gz
Include .git_keep files in role template skeleton (#24381)
setup.py will not install package_data this is just an empty directory, even if the globs in package_data match it. So the role skeleton that was being installed to galaxy/data/*/ was excluding the files/ and templates/ directories since they were empty. Since the skeleton dir doesnt include those dirs 'ansible-galaxy init' would not set them up. So this adds a .* glob to those directories so the .git_keep will be included as well, so that setup.py will create the otherwise empty directoty. ansible-galaxy init already knows to ignore those files, so no other changes are needed. (Including the .git_keep files is a little odd, but the alternative would be creating our own placeholder files. Since ansible-galaxy already understands .git_keep files we just reuse that) Fixes #23597
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py1
1 files changed, 1 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 5a89327a3f..3eaea0f5db 100644
--- a/setup.py
+++ b/setup.py
@@ -57,6 +57,7 @@ setup(
'modules/windows/*.ps1',
'modules/windows/*.ps1',
'galaxy/data/*/*.*',
+ 'galaxy/data/*/*/.*',
'galaxy/data/*/*/*.*',
'galaxy/data/*/tests/inventory'
],