summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorToshio Kuratomi <toshio@fedoraproject.org>2016-04-28 17:36:09 -0700
committerToshio Kuratomi <toshio@fedoraproject.org>2016-04-29 08:47:49 -0700
commit487e6562ca30c6097e54766ca53fb775a939c2ae (patch)
tree0436905dc7a1a1e5148615fbbe70fec033ae8e72 /setup.py
parent7af47a3886d5a2ebdc49f79564d84a336e10ffcb (diff)
downloadansible-487e6562ca30c6097e54766ca53fb775a939c2ae.tar.gz
Fix ziploader for the cornercase of ansible invoking ansible.
* Make ziploader's ansible and ansible.module_utils libraries into namespace packages. * Move __version__ and __author__ from ansible/__init__ to ansible/release.py. This is because namespace packages only load one __init__.py. If that is not the __init__.py with the author and version info then those won't be available. * In ziplaoder, move the version ito ANSIBLE_CONSTANTS. * Change PluginLoader to properly construct the path to the plugins even when namespace packages are present.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index b9678e2ab9..df6f65c453 100644
--- a/setup.py
+++ b/setup.py
@@ -4,7 +4,7 @@ import os
import sys
sys.path.insert(0, os.path.abspath('lib'))
-from ansible import __version__, __author__
+from ansible.release import __version__, __author__
try:
from setuptools import setup, find_packages
except ImportError: