summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorToshio Kuratomi <toshio@fedoraproject.org>2014-04-02 13:36:41 -0700
committerToshio Kuratomi <toshio@fedoraproject.org>2014-04-02 13:36:41 -0700
commite622074812a9af54cac7638630cccacfccd5637f (patch)
tree519b1066cb9c2256ef4218f518fcfc14a9cae786 /setup.py
parent17f134ca023fff9c8e5b5ab3910dd034b37c0391 (diff)
downloadansible-e622074812a9af54cac7638630cccacfccd5637f.tar.gz
Prnt error message is unable to use setuptools when building
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py12
1 files changed, 11 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 3ae7cedef9..166f754ac5 100644
--- a/setup.py
+++ b/setup.py
@@ -6,7 +6,17 @@ from glob import glob
sys.path.insert(0, os.path.abspath('lib'))
from ansible import __version__, __author__
-from setuptools import setup
+try:
+ from setuptools import setup
+ raise ImportError
+except ImportError:
+ print('''
+ansible now needs setuptools in order to build.
+
+Some scripts now need setuptools installed in order to run.
+ ''')
+ raise
+
# find library modules
from ansible.constants import DEFAULT_MODULE_PATH