summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorJames Laska <jlaska@ansible.com>2014-09-29 09:27:25 -0400
committerJames Laska <jlaska@ansible.com>2014-09-29 10:22:15 -0400
commita0fecd61010b6958aae46f04ce8013d3698e4482 (patch)
tree6ff10c327cb753ae88855c2b6ce0dd5a3d1d8d99 /setup.py
parent459722899d8dd618cd5bdd2ea11ed0c2810e1d5e (diff)
downloadansible-a0fecd61010b6958aae46f04ce8013d3698e4482.tar.gz
Fix packaging to work with new module location
Changes include: * Remove references to old module dir from .spec * Use setuptools find_packages find all ansible packages
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py20
1 files changed, 2 insertions, 18 deletions
diff --git a/setup.py b/setup.py
index 872dbefadb..fd3fb0a8a3 100644
--- a/setup.py
+++ b/setup.py
@@ -7,7 +7,7 @@ from glob import glob
sys.path.insert(0, os.path.abspath('lib'))
from ansible import __version__, __author__
try:
- from setuptools import setup
+ from setuptools import setup, find_packages
except ImportError:
print "Ansible now needs setuptools in order to build. " \
"Install it using your package manager (usually python-setuptools) or via pip (pip install setuptools)."
@@ -22,23 +22,7 @@ setup(name='ansible',
license='GPLv3',
install_requires=['paramiko', 'jinja2', "PyYAML", 'setuptools', 'pycrypto >= 2.6'],
package_dir={ 'ansible': 'lib/ansible' },
- packages=[
- 'ansible',
- 'ansible.cache',
- 'ansible.utils',
- 'ansible.utils.module_docs_fragments',
- 'ansible.inventory',
- 'ansible.inventory.vars_plugins',
- 'ansible.playbook',
- 'ansible.runner',
- 'ansible.runner.action_plugins',
- 'ansible.runner.lookup_plugins',
- 'ansible.runner.connection_plugins',
- 'ansible.runner.shell_plugins',
- 'ansible.runner.filter_plugins',
- 'ansible.callback_plugins',
- 'ansible.module_utils'
- ],
+ packages=find_packages('lib'),
package_data={
'': ['module_utils/*.ps1'],
},