summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorTakashi Iwai <tiwai@suse.de>2002-08-16 17:28:34 +0000
committerTakashi Iwai <tiwai@suse.de>2002-08-16 17:28:34 +0000
commit96c652f7714e3fc302fdcc0edfc067634f592c0b (patch)
treeefc64a334ae17207a6ef1d04a81eb79ae4239c8d /configure.in
parent138631aa65c4ab2835673e74b22ea2f68ae4fb9b (diff)
downloadalsa-lib-96c652f7714e3fc302fdcc0edfc067634f592c0b.tar.gz
added the descriptions for AC_DEFINE*.
withtout them, autoreconf fails.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index 40e9f631..b269228f 100644
--- a/configure.in
+++ b/configure.in
@@ -107,7 +107,7 @@ case "$dir" in
/*) ;;
*) dir="$PWD/$dir"
esac
-AC_DEFINE_UNQUOTED(DATADIR, "$dir")
+AC_DEFINE_UNQUOTED(DATADIR, "$dir", [directory containing ALSA configuration database])
dnl Check for debug...
AC_MSG_CHECKING(for debug)
@@ -117,13 +117,13 @@ AC_ARG_WITH(debug,
if test "$debug" = "yes"; then
AC_MSG_RESULT(yes)
else
- AC_DEFINE(NDEBUG)
+ AC_DEFINE(NDEBUG,,[No assert debug])
AC_MSG_RESULT(no)
fi
AC_ARG_WITH(softfloat,
[ --with-softfloat do you have floating point unit on this machine? (optional)],
- [ AC_DEFINE(HAVE_SOFT_FLOAT, "1")],)
+ [ AC_DEFINE(HAVE_SOFT_FLOAT, "1", [Avoid calculation in float])],)
dnl Check for architecture
AC_MSG_CHECKING(for architecture)