summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorClemens Ladisch <clemens@ladisch.de>2006-02-27 10:03:19 +0000
committerClemens Ladisch <clemens@ladisch.de>2006-02-27 10:03:19 +0000
commit09f598e57cc484211ab09063d47b0e05926e99a2 (patch)
tree9bd9b74294badb3be5fd32b0b647746d94ef0a9c /configure.in
parent3f00bc728ba1853cc1b010e59d6230f533c44f1c (diff)
downloadalsa-lib-09f598e57cc484211ab09063d47b0e05926e99a2.tar.gz
allow changing of device directory path
Add configuration options to change the default device path from the default /dev/snd. This is useful for embedded systems that do not want subdirectories in /dev.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in24
1 files changed, 24 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index bf11e899..c4a2b3f4 100644
--- a/configure.in
+++ b/configure.in
@@ -196,6 +196,30 @@ if test "$aload" = "yes"; then
AC_DEFINE(SUPPORT_ALOAD, "1", [Support /dev/aload* access for auto-loading])
fi
+dnl Check for non-standard /dev directory
+AC_MSG_CHECKING([for ALSA device file directory])
+AC_ARG_WITH(alsa-devdir,
+ [ --with-alsa-devdir=dir directory with ALSA device files (default /dev/snd)],
+ [alsa_dev_dir="$withval"],
+ [alsa_dev_dir="/dev/snd"])
+dnl make sure it has a trailing slash
+if echo "$alsa_dev_dir" | grep -v '/$' > /dev/null; then
+ alsa_dev_dir="$alsa_dev_dir/"
+fi
+AC_DEFINE_UNQUOTED(ALSA_DEVICE_DIRECTORY, "$alsa_dev_dir", [Directory with ALSA device files])
+AC_MSG_RESULT([$alsa_dev_dir])
+
+AC_MSG_CHECKING([for aload* device file directory])
+AC_ARG_WITH(aload-devdir,
+ [ --with-aload-devdir=dir directory with aload* device files (default /dev)],
+ [aload_dev_dir="$withval"],
+ [aload_dev_dir="/dev"])
+if echo "$aload_dev_dir" | grep -v '/$' > /dev/null; then
+ aload_dev_dir="$aload_dev_dir/"
+fi
+AC_DEFINE_UNQUOTED(ALOAD_DEVICE_DIRECTORY, "$aload_dev_dir", [Directory with aload* device files])
+AC_MSG_RESULT([$aload_dev_dir])
+
dnl Build conditions
AC_ARG_ENABLE(mixer,
[ --disable-mixer Disable the mixer component],