summaryrefslogtreecommitdiff
path: root/src/devices/bluetooth/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/devices/bluetooth/Makefile.am')
-rw-r--r--src/devices/bluetooth/Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/src/devices/bluetooth/Makefile.am b/src/devices/bluetooth/Makefile.am
index 4342d4bcdf..7840a21f53 100644
--- a/src/devices/bluetooth/Makefile.am
+++ b/src/devices/bluetooth/Makefile.am
@@ -64,6 +64,16 @@ libnm_device_plugin_bluetooth_la_LIBADD = \
$(DBUS_LIBS) \
$(GUDEV_LIBS)
+if WITH_BLUEZ5_DUN
+AM_CPPFLAGS += $(BLUEZ5_CFLAGS)
+
+libnm_device_plugin_bluetooth_la_SOURCES += \
+ nm-bluez5-dun.c \
+ nm-bluez5-dun.h
+
+libnm_device_plugin_bluetooth_la_LIBADD += $(BLUEZ5_LIBS)
+endif
+
CLEANFILES = $(BUILT_SOURCES)
EXTRA_DIST = $(SYMBOL_VIS_FILE)