summaryrefslogtreecommitdiff
path: root/libnm-glib/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'libnm-glib/tests/Makefile.am')
-rw-r--r--libnm-glib/tests/Makefile.am7
1 files changed, 5 insertions, 2 deletions
diff --git a/libnm-glib/tests/Makefile.am b/libnm-glib/tests/Makefile.am
index 7b8f3627e2..6ce91dd931 100644
--- a/libnm-glib/tests/Makefile.am
+++ b/libnm-glib/tests/Makefile.am
@@ -12,6 +12,11 @@ AM_CPPFLAGS = \
noinst_PROGRAMS = $(TESTS)
+if WITH_VALGRIND
+@VALGRIND_RULES@ --launch-dbus
+else
+TESTS_ENVIRONMENT = $(srcdir)/libnm-test-launch.sh
+endif
TESTS = test-nm-client test-remote-settings-client
####### NMClient and non-settings tests #######
@@ -42,8 +47,6 @@ test_remote_settings_client_LDADD = \
###########################################
-TESTS_ENVIRONMENT = $(srcdir)/libnm-glib-test-launch.sh
-
endif
EXTRA_DIST = libnm-glib-test-launch.sh