summaryrefslogtreecommitdiff
path: root/libnm-glib/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'libnm-glib/meson.build')
-rw-r--r--libnm-glib/meson.build15
1 files changed, 15 insertions, 0 deletions
diff --git a/libnm-glib/meson.build b/libnm-glib/meson.build
index a236ec08bd..eddf983e49 100644
--- a/libnm-glib/meson.build
+++ b/libnm-glib/meson.build
@@ -276,3 +276,18 @@ run_target(
if enable_tests
subdir('tests')
endif
+
+pkg.generate(
+ version: nm_version,
+ name: nm_name,
+ description: 'System for maintaining active network connection',
+ filebase: nm_name,
+ subdirs: nm_name,
+ requires: '',
+ variables: [
+ 'exec_prefix=${prefix}',
+ 'libgnome_serverdir=' + nm_libexecdir,
+ 'plugindir=' + nm_pkglibdir,
+ 'configdir=' + nm_pkgconfdir
+ ]
+)