summaryrefslogtreecommitdiff
path: root/docs/libnm/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'docs/libnm/Makefile.am')
-rw-r--r--docs/libnm/Makefile.am21
1 files changed, 16 insertions, 5 deletions
diff --git a/docs/libnm/Makefile.am b/docs/libnm/Makefile.am
index 1e1e9ae276..28938f89ff 100644
--- a/docs/libnm/Makefile.am
+++ b/docs/libnm/Makefile.am
@@ -10,7 +10,11 @@ DOC_MAIN_SGML_FILE=$(DOC_MODULE)-docs.xml
# The directory containing the source code. Relative to $(srcdir).
# gtk-doc will search all .c & .h files beneath here for inline comments
# documenting functions and macros.
-DOC_SOURCE_DIR=$(top_srcdir)/libnm-core $(top_srcdir)/libnm
+DOC_SOURCE_DIR= \
+ $(top_srcdir)/libnm-core \
+ $(top_builddir)/libnm-core \
+ $(top_srcdir)/libnm \
+ $(top_builddir)/libnm
# Extra options to supply to gtkdoc-scan.
SCAN_OPTIONS=--rebuild-types --rebuild-sections
@@ -30,19 +34,26 @@ CFILE_GLOB=$(top_srcdir)/libnm-core/*.c $(top_srcdir)/libnm/*.c
# Header files to ignore when scanning.
IGNORE_HFILES= \
+ common.h \
crypto.h \
- nm-dbus-helpers-private.h \
+ nm-dbus-helpers.h \
nm-core-internal.h \
+ nm-core-types.h \
nm-device-private.h \
+ nm-dhcp4-config.h \
+ nm-dhcp6-config.h \
+ nm-ip4-config.h \
+ nm-ip6-config.h \
nm-manager.h \
nm-object-cache.h \
nm-object-private.h \
- nm-param-spec-dbus.h \
+ nm-property-compare.h \
nm-remote-connection-private.h \
nm-remote-settings.h \
nm-setting-private.h \
- nm-types-private.h \
- nm-utils-private.h
+ nm-types.h \
+ nm-utils-private.h \
+ nm-vpn-plugin-old.h
# Images to copy into HTML directory.
HTML_IMAGES = libnm.png