summaryrefslogtreecommitdiff
path: root/docs/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'docs/Makefile.am')
-rw-r--r--docs/Makefile.am27
1 files changed, 27 insertions, 0 deletions
diff --git a/docs/Makefile.am b/docs/Makefile.am
new file mode 100644
index 0000000000..220df46621
--- /dev/null
+++ b/docs/Makefile.am
@@ -0,0 +1,27 @@
+SUBDIRS = libnm-glib libnm-util
+
+if WITH_DOCS
+
+XSLTPROC = xsltproc --xinclude --nonet
+XMLS = $(wildcard $(top_srcdir)/introspection/nm-*.xml)
+
+OTHER_FILES= \
+ $(top_srcdir)/introspection/all.xml \
+ $(top_srcdir)/introspection/generic-types.xml \
+ $(top_srcdir)/introspection/errors.xml \
+ $(top_srcdir)/introspection/vpn-errors.xml \
+ $(top_srcdir)/tools/doc-generator.xsl \
+ $(top_srcdir)/introspection/generic-types.xml
+
+GENERATED_FILES = spec.html
+
+spec.html: $(XMLS) $(OTHER_FILES)
+ @install -d docs
+ $(XSLTPROC) $(top_srcdir)/tools/doc-generator.xsl $(top_srcdir)/introspection/all.xml > $@
+
+EXTRA_DIST = $(GENERATED_FILES)
+
+CLEANFILES = $(GENERATED_FILES)
+
+endif
+