summaryrefslogtreecommitdiff
path: root/system-settings/plugins/ifupdown/tests/Makefile.am
diff options
context:
space:
mode:
authorDan Williams <dcbw@redhat.com>2011-01-02 17:24:23 -0600
committerDan Williams <dcbw@redhat.com>2011-01-02 17:24:23 -0600
commit0587ef1179c7abb1c83ff5d12ce8e1b587ed0625 (patch)
tree7e66edf56183e99552e17044433e6eb234359d0b /system-settings/plugins/ifupdown/tests/Makefile.am
parentb2f9747dba513fd34dac2b427ad1e0ac6ccb31e9 (diff)
parent15a9f29a14783fcd1b8e936a8338452737825726 (diff)
downloadNetworkManager-0587ef1179c7abb1c83ff5d12ce8e1b587ed0625.tar.gz
Merge remote branch 'origin/master' into wimax
Diffstat (limited to 'system-settings/plugins/ifupdown/tests/Makefile.am')
-rw-r--r--system-settings/plugins/ifupdown/tests/Makefile.am32
1 files changed, 32 insertions, 0 deletions
diff --git a/system-settings/plugins/ifupdown/tests/Makefile.am b/system-settings/plugins/ifupdown/tests/Makefile.am
new file mode 100644
index 0000000000..b5dbd13d63
--- /dev/null
+++ b/system-settings/plugins/ifupdown/tests/Makefile.am
@@ -0,0 +1,32 @@
+INCLUDES = \
+ -I$(top_srcdir)/include \
+ -I$(top_srcdir)/libnm-util \
+ -I$(top_srcdir)/libnm-glib \
+ -I$(top_srcdir)/system-settings/plugins/ifupdown
+
+noinst_PROGRAMS = test-ifupdown
+
+test_ifupdown_SOURCES = \
+ test-ifupdown.c
+
+test_ifupdown_CPPFLAGS = \
+ $(GLIB_CFLAGS) \
+ $(DBUS_CFLAGS) \
+ -DTEST_ENI_DIR=\"$(abs_srcdir)\"
+
+test_ifupdown_LDADD = \
+ $(top_builddir)/libnm-glib/libnm-glib.la \
+ $(top_builddir)/libnm-util/libnm-util.la \
+ $(top_builddir)/system-settings/plugins/ifupdown/libifupdown-io.la \
+ $(DBUS_LIBS)
+
+if WITH_TESTS
+
+check-local: test-ifupdown
+ $(abs_builddir)/test-ifupdown
+
+endif
+
+EXTRA_DIST = \
+ test1 test2 test3 test4 test5 test6 test7 test8 test9 test11 test12 \
+ test13 test14 test15 test16