summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorThomas Haller <thaller@redhat.com>2016-09-27 13:35:29 +0200
committerThomas Haller <thaller@redhat.com>2016-09-27 14:13:21 +0200
commite3a072f3c0d8046a9c1d01c8518c532b71f7bd7a (patch)
treefc59e7b009a14227dd825be31ad7bd0c59b41ae9 /src/Makefile.am
parent3f4aa48d6bc7302ffb38eda2d3c674f747516f37 (diff)
downloadNetworkManager-e3a072f3c0d8046a9c1d01c8518c532b71f7bd7a.tar.gz
build: don't add systemd path the include search path
Our internal copy of systemd should not be in the search path. Instead, let users only #include "systemd/nm-sd.h" which then includes everything from systemd that we need. We want to avoid to accidentally include anything from our systemd-copy. Any user of that should only include "nm-sd.h", which then includes everything that is needed further. For example, "src/devices/wwan/nm-modem-manager.c" has #include <systemd/nm-daemon.h> which in turn includes #include "_sd-common.h" This works all correctly before, because #include "" will first look in the directory where sd-daemon.h is. However, our mixing of external systemd library and internal copy is rather dangerous. Try to avoid it further by keeping the include paths clean.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am3
1 files changed, 0 insertions, 3 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 10f63ded44..f08acecc0d 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -76,9 +76,6 @@ AM_CPPFLAGS = \
$(SYSTEMD_JOURNAL_CFLAGS) \
$(CODE_COVERAGE_CFLAGS) \
\
- -I$(top_srcdir)/src/systemd/src/systemd/ \
- -I$(top_srcdir)/src/systemd/ \
- \
$(NULL)
AM_LDFLAGS = $(CODE_COVERAGE_LDFLAGS)