summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorDan Williams <dcbw@redhat.com>2014-02-10 18:57:09 -0600
committerDan Williams <dcbw@redhat.com>2014-03-03 09:32:41 -0600
commitaeb1e103d809210c4fffb719e72f3b9fb1c8fb90 (patch)
tree51ac29c802518d17c56beee2d3432048c1775e64 /src/Makefile.am
parenta9591aecaf0118f8e603a4ed0a40f3ea8535529b (diff)
downloadNetworkManager-aeb1e103d809210c4fffb719e72f3b9fb1c8fb90.tar.gz
mobile: make WWAN support a plugin
Make WWAN support a plugin using the new device factory interface. Provides a 5% size reduction in the core NM binary. Before After NM: 1187224 1125208 (-5%) MM: 0 100576 (all results from stripped files)
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am20
1 files changed, 1 insertions, 19 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index a50932ed20..fd0bb6964c 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -5,6 +5,7 @@ include $(GLIB_MAKEFILE)
SUBDIRS = \
. \
devices/atm \
+ devices/wwan \
devices/bluetooth \
dhcp-manager \
ppp-manager \
@@ -76,8 +77,6 @@ nm_sources = \
devices/nm-device-infiniband.h \
devices/nm-device-macvlan.c \
devices/nm-device-macvlan.h \
- devices/nm-device-modem.c \
- devices/nm-device-modem.h \
devices/nm-device-olpc-mesh.c \
devices/nm-device-olpc-mesh.h \
devices/nm-device-private.h \
@@ -123,14 +122,6 @@ nm_sources = \
logging/nm-logging.c \
logging/nm-logging.h \
\
- modem-manager/nm-modem-old.c \
- modem-manager/nm-modem-old.h \
- modem-manager/nm-modem-old-types.h \
- modem-manager/nm-modem-manager.c \
- modem-manager/nm-modem-manager.h \
- modem-manager/nm-modem.c \
- modem-manager/nm-modem.h \
- \
platform/nm-fake-platform.c \
platform/nm-fake-platform.h \
platform/nm-linux-platform.c \
@@ -259,12 +250,6 @@ nm_sources = \
NetworkManagerUtils.c \
NetworkManagerUtils.h
-if WITH_MODEM_MANAGER_1
-nm_sources += \
- modem-manager/nm-modem-broadband.c \
- modem-manager/nm-modem-broadband.h
-endif
-
if SESSION_TRACKING_SYSTEMD
nm_sources += nm-session-monitor-systemd.c
else
@@ -312,7 +297,6 @@ glue_sources = \
nm-device-gre-glue.h \
nm-device-infiniband-glue.h \
nm-device-macvlan-glue.h \
- nm-device-modem-glue.h \
nm-device-olpc-mesh-glue.h \
nm-device-team-glue.h \
nm-device-tun-glue.h \
@@ -342,7 +326,6 @@ AM_CPPFLAGS += \
$(LIBNL_CFLAGS) \
$(LIBNDP_CFLAGS) \
$(LIBSOUP_CFLAGS) \
- $(MM_GLIB_CFLAGS) \
$(POLKIT_CFLAGS) \
$(SYSTEMD_LOGIN_CFLAGS) \
\
@@ -385,7 +368,6 @@ libNetworkManager_la_LIBADD = \
$(GLIB_LIBS) \
$(GUDEV_LIBS) \
$(LIBNL_LIBS) \
- $(MM_GLIB_LIBS) \
$(POLKIT_LIBS) \
$(SYSTEMD_LOGIN_LIBS) \
$(LIBDL) \