summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorThomas Haller <thaller@redhat.com>2019-02-22 08:38:54 +0100
committerThomas Haller <thaller@redhat.com>2019-02-23 07:20:49 +0100
commitb1f6d53bc442de3fac52462bcfdf07900a89d241 (patch)
tree41df987ccc03341872f813ae9725bcb5ba92795f /meson.build
parent8f62c76c0a7590535c87e6095af419e5c9dbc8c1 (diff)
downloadNetworkManager-b1f6d53bc442de3fac52462bcfdf07900a89d241.tar.gz
build/meson: increase timeouts for some tests
The defaults for test timeouts in meson is 30 seconds. That is not long enough when running $ NMTST_USE_VALGRIND=1 ninja -C build test Note that meson supports --timeout-multiplier, and automatically increases the timeout when running under valgrind. However, meson does not understand that we are running tests under valgrind via NMTST_USE_VALGRIND=1 environment variable. Timeouts are really not expected to be reached and are a mean of last resort. Hence, increasing the timeout to a large value is likely to have no effect or to fix test failures where the timeout was too rigid. It's unlikely that the test indeed hangs and the increase of timeout causes a unnecessary increase of waittime before aborting.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 2 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 19926aeb12..b0dc801b98 100644
--- a/meson.build
+++ b/meson.build
@@ -98,6 +98,8 @@ set_defines = [
['VERSION', nm_version],
]
+default_test_timeout = 90
+
foreach define: set_defines
config_h.set_quoted(define[0], define[1])
endforeach