summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorLubomir Rintel <lkundrak@v3.sk>2019-04-03 08:52:38 +0200
committerLubomir Rintel <lkundrak@v3.sk>2019-04-03 08:52:38 +0200
commitb027723e00679f2b709880407a6ff24583faeae3 (patch)
treeb972843460a92d737edb7512444b24791118f9de /meson.build
parent61aad8cda475a07d579a85f209696d1ff8fd3e84 (diff)
downloadNetworkManager-b027723e00679f2b709880407a6ff24583faeae3.tar.gz
Revert "all: goodbye libnm-glib"
We need this for a little little longer :( This reverts commit 1de8383ad9fdfc8f552117e5d109bdfa7005634b.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build37
1 files changed, 37 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index a6643473f9..ee74e54d76 100644
--- a/meson.build
+++ b/meson.build
@@ -63,6 +63,28 @@ libnm_version = '@0@.@1@.@2@'.format(current - age, age, revision)
libnm_pkgincludedir = join_paths(nm_includedir, libnm_name)
+libnm_util_name = 'libnm-util'
+
+current = 9
+revision = 0
+age = 7
+libnm_util_version = '@0@.@1@.@2@'.format(current - age, age, revision)
+
+libnm_glib_name = 'libnm-glib'
+libnm_glib_vpn_name = libnm_glib_name + '-vpn'
+
+current = 13
+revision = 0
+age = 9
+libnm_glib_version = '@0@.@1@.@2@'.format(current - age, age, revision)
+
+libnm_glib_pkgincludedir = join_paths(nm_includedir, libnm_glib_name)
+
+current = 3
+revision = 0
+age = 2
+libnm_glib_vpn_version = '@0@.@1@.@2@'.format(current - age, age, revision)
+
nm_debug = get_option('buildtype').contains('debug')
cc = meson.get_compiler('c')
@@ -298,6 +320,15 @@ if enable_introspection
assert(gir_dep.found(), 'introspection support was requested, but the gobject-introspection library is not available. Use -Dintrospection=false to build without it.')
endif
+enable_libnm_glib = get_option('libnm_glib')
+if enable_libnm_glib
+ dbus_glib_dep = dependency('dbus-glib-1', version: '>= 0.94', required: false)
+ assert(dbus_dep.found() and dbus_glib_dep.found(), 'Configure with -Dlibnm_glib=false if you do not need the legacy libraries')
+endif
+# FIXME: do this better!!!
+have_fake_typelibs = enable_libnm_glib and enable_introspection
+config_h.set10('WITH_FAKE_TYPELIBS', have_fake_typelibs)
+
udev_dir = get_option('udev_dir')
install_udev_dir = (udev_dir != 'no')
@@ -826,6 +857,11 @@ subdir('clients')
subdir('data')
subdir('po')
+if enable_libnm_glib
+ subdir('libnm-util')
+ subdir('libnm-glib')
+endif
+
if enable_vapi
subdir('vapi')
endif
@@ -936,6 +972,7 @@ output += ' ofono: ' + enable_ofono.to_string() + '\n'
output += ' concheck: ' + enable_concheck.to_string() + '\n'
output += ' libteamdctl: ' + enable_teamdctl.to_string() + '\n'
output += ' ovs: ' + enable_ovs.to_string() + '\n'
+output += ' libnm-glib: ' + enable_libnm_glib.to_string() + '\n'
output += ' nmcli: ' + enable_nmcli.to_string() + '\n'
output += ' nmtui: ' + enable_nmtui.to_string() + '\n'
output += '\nConfiguration_plugins (main.plugins=' + config_plugins_default + ')\n'