summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorThomas Haller <thaller@redhat.com>2019-06-19 07:47:20 +0200
committerThomas Haller <thaller@redhat.com>2019-06-20 16:06:44 +0200
commit74641be816a201fdb704a7a8084a791ea5c76c9f (patch)
treea7210659ef1602fbfa941d8ea18c6a560c732995 /meson.build
parentf182d4fa20634ae8691757721b0e925ddb0af4cb (diff)
downloadNetworkManager-74641be816a201fdb704a7a8084a791ea5c76c9f.tar.gz
settings: drop ibft settings pluginth/drop-ibft-settings-plugin
The functionality of the ibft settings plugin is now handled by nm-initrd-generator. There is no need for it anymore, drop it. Note that ibft called iscsiadm, which requires CAP_SYS_ADMIN to work ([1]). We really want to drop this capability, so the current solution of a settings plugin (as it is implemented) is wrong. The solution instead is nm-initrd-generator. Also, on Fedora the ibft was disabled and probably on most other distributions as well. This was only used on RHEL. [1] https://bugzilla.redhat.com/show_bug.cgi?id=1371201#c7
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build8
1 files changed, 0 insertions, 8 deletions
diff --git a/meson.build b/meson.build
index 6aa4ba5331..bfeaa3eb74 100644
--- a/meson.build
+++ b/meson.build
@@ -233,9 +233,6 @@ endif
enable_ifcfg_rh = get_option('ifcfg_rh') or (distro == 'redhat')
enable_ifupdown = get_option('ifupdown') or (distro == 'debian')
-enable_ibft = get_option('ibft')
-
-config_h.set10('WITH_SETTINGS_PLUGIN_IBFT', enable_ibft)
config_plugins_default = get_option('config_plugins_default')
if config_plugins_default == ''
@@ -249,10 +246,6 @@ if config_plugins_default == ''
config_plugins += ['ifupdown']
endif
- if enable_ibft
- config_plugins += ['ibft']
- endif
-
config_plugins_default = ','.join(config_plugins)
endif
config_h.set_quoted('NM_CONFIG_DEFAULT_MAIN_PLUGINS', config_plugins_default)
@@ -937,7 +930,6 @@ output += ' ovs: ' + enable_ovs.to_string() + '\n'
output += ' nmcli: ' + enable_nmcli.to_string() + '\n'
output += ' nmtui: ' + enable_nmtui.to_string() + '\n'
output += '\nConfiguration_plugins (main.plugins=' + config_plugins_default + ')\n'
-output += ' ibft: ' + enable_ibft.to_string() + '\n'
output += ' ifcfg-rh: ' + enable_ifcfg_rh.to_string() + '\n'
output += ' ifupdown: ' + enable_ifupdown.to_string() + '\n'
output += '\nHandlers for /etc/resolv.conf:\n' + resolv_conf_summary