summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorAntonio Cardace <acardace@redhat.com>2019-12-20 12:25:48 +0100
committerAntonio Cardace <acardace@redhat.com>2019-12-23 11:05:50 +0100
commiteaa26408f351e77ff044edc01d113b26d87fd63e (patch)
tree11de1d772d43a0f24871effd986d671c79efd74b /meson.build
parent6dc816758801caa84c4e8df8e235497a76efade3 (diff)
downloadNetworkManager-eaa26408f351e77ff044edc01d113b26d87fd63e.tar.gz
meson: remove pid_t redefinition
For some reason has_type() does not work correctly and causes redefinition of the type.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 0 insertions, 4 deletions
diff --git a/meson.build b/meson.build
index 095b2689ad..14046f5a55 100644
--- a/meson.build
+++ b/meson.build
@@ -137,10 +137,6 @@ config_h.set('SIZEOF_INO_T', cc.sizeof('ino_t', prefix : '#include <sys/types.h>
config_h.set('SIZEOF_TIME_T', cc.sizeof('time_t', prefix : '#include <sys/time.h>'))
config_h.set('SIZEOF_RLIM_T', cc.sizeof('rlim_t', prefix : '#include <sys/resource.h>'))
-if not cc.has_type('pid_t', prefix: '#include <sys/types.h>')
- config_h.set('pid_t', 'int')
-endif
-
# compiler flags
common_flags = []
common_ldflags = []