summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorIñigo Martínez <inigomartinez@gmail.com>2019-09-11 13:00:54 +0200
committerThomas Haller <thaller@redhat.com>2019-10-01 09:49:33 +0200
commit700f6f6b5fd5dd9975200cb22a9251e811963d47 (patch)
treef077a9b215501e27bf7f84ecf8c629a0ae5652bb /meson.build
parentda40a6597fb37bd49bb1c7b01954de199ffed740 (diff)
downloadNetworkManager-700f6f6b5fd5dd9975200cb22a9251e811963d47.tar.gz
meson: Improve Qt examples
Qt dependencies have been moved to the main build file where the rest of dependencies are located. This makes it easier to find them. The included directories has also reviewed and removed the unnecessary ones.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build5
1 files changed, 5 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 969ac382d5..4f93dd3a9a 100644
--- a/meson.build
+++ b/meson.build
@@ -840,6 +840,11 @@ subdir('examples/C/glib')
enable_qt = get_option('qt')
if enable_qt
add_languages('cpp')
+
+ qt_core_dep = dependency('QtCore', version: '>= 4')
+ qt_dbus_dep = dependency('QtDBus')
+ qt_network_dep = dependency('QtNetwork')
+
subdir('examples/C/qt')
endif