summaryrefslogtreecommitdiff
path: root/libnm/tests/Makefile.am
diff options
context:
space:
mode:
authorDan Winship <danw@gnome.org>2014-07-04 13:26:57 -0400
committerDan Winship <danw@gnome.org>2014-08-01 14:34:04 -0400
commiteedcf185a7615c68281f2dc33f315efbaeee93c8 (patch)
tree869bf573f7863e374acf89d7c56bd06f094097fd /libnm/tests/Makefile.am
parentd595f7843e31e8312c0baf25b476b6489cff59a7 (diff)
downloadNetworkManager-eedcf185a7615c68281f2dc33f315efbaeee93c8.tar.gz
libnm: add libnm/libnm-core (part 2)
This fixes up the code from the previous "clean" import, and adds build infrastructure. [There are two slightly orthogonal sets of changes in this patch. First, the files added in the previous commit were modified as followed: # Replace internal references to "libnm-util" and "libnm-glib" with "libnm" perl -pi -e 's/libnm-(util|glib)/libnm/;' libnm-core/*.[ch] libnm-core/tests/*.[ch] libnm/*.[ch] libnm/tests/*.[ch] # Fix includes of the enum-types files perl -pi -e 's/nm-utils-enum-types/nm-core-enum-types/;' libnm-core/*.[ch] libnm-core/tests/*.[ch] libnm/*.[ch] libnm/tests/*.[ch] perl -pi -e 's/nm-glib-enum-types/nm-enum-types/;' libnm/*.[ch] libnm/tests/*.[ch] # Fix some python example code perl -pi -e 's/import NMClient/import NM/;' -e 's/NMClient.Client\(\)/NM.Client()/;' libnm/nm-client.c Then, the build infrastructure was added (without further modifying any existing files in libnm-core or libnm.) Note: to regenerate libnm.ver after rebase: (head -2 libnm-util/libnm-util.ver; (grep -h '\s'nm_ libnm-util/libnm-util.ver libnm-glib/libnm-glib.ver | env LANG=C sort); tail -3 libnm-util/libnm-util.ver) > libnm/libnm.ver ]
Diffstat (limited to 'libnm/tests/Makefile.am')
-rw-r--r--libnm/tests/Makefile.am37
1 files changed, 37 insertions, 0 deletions
diff --git a/libnm/tests/Makefile.am b/libnm/tests/Makefile.am
new file mode 100644
index 0000000000..cda638a83f
--- /dev/null
+++ b/libnm/tests/Makefile.am
@@ -0,0 +1,37 @@
+if ENABLE_TESTS
+
+AM_CPPFLAGS = \
+ -I$(top_srcdir)/include \
+ -I$(top_srcdir)/libnm \
+ -I$(top_builddir)/libnm \
+ -I$(top_srcdir)/libnm-core \
+ -I$(top_builddir)/libnm-core \
+ -DNM_VERSION_MAX_ALLOWED=NM_VERSION_NEXT_STABLE \
+ -DTEST_NM_SERVICE=\"$(abs_top_srcdir)/tools/test-networkmanager-service.py\" \
+ $(GLIB_CFLAGS) \
+ $(DBUS_CFLAGS)
+
+LDADD = \
+ $(top_builddir)/libnm/libnm.la \
+ $(GLIB_LIBS) \
+ $(DBUS_LIBS)
+
+noinst_PROGRAMS = $(TESTS)
+
+TESTS = test-nm-client test-remote-settings-client
+
+test_nm_client_SOURCES = \
+ common.c \
+ common.h \
+ test-nm-client.c
+
+test_remote_settings_client_SOURCES = \
+ common.c \
+ common.h \
+ test-remote-settings-client.c
+
+TESTS_ENVIRONMENT = $(srcdir)/libnm-test-launch.sh
+
+endif
+
+EXTRA_DIST = libnm-test-launch.sh