summaryrefslogtreecommitdiff
path: root/libnm/meson.build
diff options
context:
space:
mode:
authorIñigo Martínez <inigomartinez@gmail.com>2017-12-15 14:35:31 +0100
committerThomas Haller <thaller@redhat.com>2017-12-16 15:12:33 +0100
commit28914f6a68888d42cd6e7f3dd906df47199e9b39 (patch)
tree823958b5e79e01fa1dbf1d8f071334bbb45addf0 /libnm/meson.build
parent22ffd53369d89bd8b7f34a20800dee9ca287f7e2 (diff)
downloadNetworkManager-28914f6a68888d42cd6e7f3dd906df47199e9b39.tar.gz
build: Make generate-plugin-docs.pl independent of autotools
`generate-plugin-docs.pl` script which is used to parse `nm-setting-c*.c` files depends on autotools. This is because it parses the `Makefile.am` in order to figure out the setting files it needs to parse. This patch makes the script independent of autotools by passing the necessary setting files by command line instead of parsing the `Makefile.am` file. It also changes the autotools' and meson's accordingly.
Diffstat (limited to 'libnm/meson.build')
-rw-r--r--libnm/meson.build12
1 files changed, 6 insertions, 6 deletions
diff --git a/libnm/meson.build b/libnm/meson.build
index 3541832a5c..d06c379dd6 100644
--- a/libnm/meson.build
+++ b/libnm/meson.build
@@ -236,26 +236,26 @@ if enable_introspection
name = 'nm-settings-keyfile-docs.xml'
nm_settings_keyfile_docs = custom_target(
name,
- input: meson.source_root(),
+ input: libnm_core_settings_sources,
output: name,
- command: [perl, generate_plugin_docs, 'keyfile', '@INPUT@', '@OUTPUT@']
+ command: [perl, generate_plugin_docs, 'keyfile', '@OUTPUT@', '@INPUT@']
)
name = 'nm-settings-docs-overrides.xml'
nm_settings_docs_overrides = custom_target(
name,
- input: meson.source_root(),
+ input: libnm_core_settings_sources,
output: name,
- command: [perl, generate_plugin_docs, 'dbus', '@INPUT@', '@OUTPUT@']
+ command: [perl, generate_plugin_docs, 'dbus', '@OUTPUT@', '@INPUT@']
)
if enable_ifcfg_rh
name = 'nm-settings-ifcfg-rh-docs.xml'
nm_settings_ifcfg_rh_docs = custom_target(
name,
- input: meson.source_root(),
+ input: libnm_core_settings_sources,
output: name,
- command: [perl, generate_plugin_docs, 'ifcfg-rh', '@INPUT@', '@OUTPUT@']
+ command: [perl, generate_plugin_docs, 'ifcfg-rh', '@OUTPUT@', '@INPUT@']
)
endif